AMSv3.14 Release - Issue with HQ Player (semi-fixed by Matt at AA). HQ player not stable

Hi everyone,

CX/EX owner here.

Last night I updated to AMS v3.14, and although I could get my system playing through Roon or Squeeze, I couldn’t get HQ Player working again.

Matt came to the rescue this morning, although it took a lot of experimenting to get it working. The main issue seemed to be the PCM Settings Rate Limit. I have a DAC which can handle 192K upsampling, and I had the Rate limit set somewhere at this point or maybe above.

HQ Player now only works if I took the Rate Limit down to 128,000. I don’t fully understand what change in AMS might have caused this (or even if it did), but now I know that it won’t work without this setting reduced.

Matt swapped the HQ Player processing over to my CX which theoretically should be better due to having more processing power, so that was one helpful outcome.

Hope all your upgrades are going smoothly.


Would you share a screenshot of your settings?

Also, on the Player dashboard, click the Audio Diagnostics button. A report will be displayed. You should see the list of rates that your DAC supports. Please share that.

This is what I see for my DAC:

Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000

Note that this might be repeated for multiple interfaces. It should remain the same for each but if it does not share it here as well.

It hasn’t been very stable since the update unfortunately. It has dropped out a few times and required me to reset HQ Player or the Player Dashboard.

In regards to the Audio diagnostics:

Diagnostic information for this Output Device

MOUSAI Audio Technology Co.,Ltd Questyle Hi-end USB Audio at usb-0000:00:14.0-2 : USB Audio #1

Status: Stop
Interface 1
Altset 3
Channels: 2
Endpoint: 5 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000
Data packet interval: 125 us
Bits: 64
Status: Unknown (status not available when device is not playing)
Simple mixer control ‘PCM’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]

Thanks for providing the extra details. Your DAC clearly supports 192K so that should be working for you.

Try this:
Set Output mode to auto
Under PCM set 1x, Nx and dither to None
Set rate limit to 192000
(optional: set min and max volume to 0)

I hope you have a track that’s already 192k, because playing this would be a good test to do at this point. HQPlayer should just pass it through without processing so this will help us rule out other issues.

Thanks for the suggestions. I have made the changes. It does play 192k now, but it doesn’t seem to improve the stability issues.

Can you describe the stability issues?

I think if you are seeing stability issues despite setting HQPlayer to minimum processing, there is an issue elsewhere - like maybe with a cable.

If you switch to Squeeze can you play that same 192k track without issues?

Squeeze and Roon work fine. The stability issues relate to the fact that every time I stop playing music (eg to take a phone call) and then re-start it, I now need to re-click the Apply button on the HQ Player settings page. My authentication key is there and showing, but it might be treating me like a trial customer for some reason. I think the last log-in was done as Admin/Admin, but now I can’t remember whether I created a new log-in or not. Do you know if there is a way to log-out and log back in again?

Yes that is likely! Click on About tab on the HQPlayer config. License should be your name. If you see Trial instead, you’ll have to provide Jussi the fingerprint so he can issue you a new key.

Thanks for the advice! I’ve written to Signalist and let’s see if they respond.

1 Like

@kennyb123 Do you know if there is a trick to getting them to respond? I wrote to and no response for 48 hours?

I think I had to ping him a second time on one occasion. The other time the turnaround was quick.

1 Like

Jussi has been pretty quick when I have emailed him- 24 hours at the most each time…