Anyone else out there using HQPlayer through Roon?

I’ve been playing with the various PCM filters on HQPlayer and my favourite so far seems to be Sinc-L. However, there is a 4-5 second delay when playing a track. This means that the end of each track is cut off when the player reaches 4-5 seconds before the end and loads the next track. I assume this is due to an EX hardware limitation? If so, is there anything that can be confgured to account for the delay?

Actually, this only seems to happen when playing an album of unrelated tracks through Roon. The cutting off of the end of tracks doesn’t happen when playing a complete album…Could this be a Roon thing?

That delay is due to the filter you selected. It takes time to reconstruct the data. You should try sinc-M as it shoots for only a million taps, while te sinc-L filter is adaptive and has the potential to go beyond a million taps.

I’ve never experienced any cutting off of tracks.

Can you post a screenshot of your HQPlayer settings?

Hi Kenny. Thanks for the reply. There is still a 4-5 second delay with Sinc-M from start and also when I press pause from Roon Remote on my iPad. Here are my HQPlayer settings on the EX.


My DAC, in case it helps, is a Denafrips Venus II.

CX HQplayer Server settings:

Thanks for sharing the screenshots. Your setup is different than mine in that I only see these settings on my K30server. The K30player is running only NAA.

If you are running Roon Core off your CX, then the settings that should matter are the ones on the CX. But please confirm that within Roon under Settings…Setup that you see this:

If so then it’s the CX’s HQPlayer settings that matter. Try setting the PCM settings to pass-through and play only PCM tracks and see if the delay vanishes.

Let me know.

These are the settings I use when using Roon:

Hi Kenny. Thanks for replying. As per the manual here (https://antipodes.audio/amsv2-guide/?page=91) I entered the address of the EX into Roon Remote. And the CX is listed as the Roon Core. As I understand it, if the HQPlayer Backend is set to Network Audio on the CX, and Device is set to the EX, it should just serve data to the EX? And the output (filters, etc) is only configured on the EX. This is how I understand it to work anyway. Perhaps @MarkCole can answer this?

By the way, the delay is higher for source recorded at a higher rate, so for example, if the source is 44.1kHz 16 bit the delay is ~2 seconds, but for 48kHz or 96kHz 24 bit it is ~4 seconds.

I’m not sure I agree that it should be the EX’s address that Roon is configured to use as that puts heavy processing on the box feeding the DAC. Mark will have to weigh in.

For now, I will focus on your HQPlayer settings on the EX. I recommend the following:

Enable fixed volume. Set this to 0 (for now).
Turn off adaptive volume (as this may contribute to a delay)
Set rate limit to 768000 for PCM
Set dither to LNS15

I wonder if that is a result of your rate limit set to 705600. It should be a multiple of 48 Hz so 768000.

For some reason 768000 causes static-like noise on some tracks…

By the way, I can’t get DSD256 or DSD512 output working either. Again, I’ve tried different outputs and modulators.

Which USB cable are you using? If the USB cable deviates from spec, I believe one could potentially hear static at 768K.

Change Output Mode on the EX to Auto and DSD should start to play again. But, DSD256 or DSD512 is too much to ask for the CPU in the EX. “Only high intensity computations like transcoding/upsampling to DSD256 and DSD512 on-the-fly are too demanding” per this.

The CX can handle this though.

Hi Kenny, My USB cable is the Final Touch Audio USB. I think I shall try using the localhost setting you describe. Some more research online would suggest that I have configured this incorrectly. If this is the case it probably means buying another HQPlayer license for my CX, as I have applied mine to the EX…

The Callisto is well regarded. My concern though is with this statement from their website: “Sometimes deviation from current regular practices and trends might bring tangible results and our firm belief is that with Callisto USB cable we managed to achieve that.” If you are curious as to whether this cable is the culprit behind you hearing static at 768K, just try a generic USB that meets spec and see if the static vanishes.

As far as your HQPlayer license, maybe the developer, Jussi, can swap it out for you. It wouldn’t hurt to ask.

I use the FTA Callisto usb in my system and it has worked faultlessly no matter what files I use eg 768 PGGB.

Great to know that yours works faultlessly. It may still be worthwhile for @mreid to eliminate his USB cable as the culprit behind the crackling.

1 Like

Hi Kenny. I tried entering localhost but no sound was forthcoming at all. This document (https://antipodes.audio/amsv2-guide/?page=91) would suggest I configured it correctly anyhow when running Roon Server with HQPlayer:

Connect Roon to HQPlayer

Now, in Roon Remote, go to Settings/Setup/HQPlayer and click ‘Add HQPlayer’. Input the IP address of the Antipodes that connects to your

DAC (eg in a CX+EX solution, input the IP address of the EX).

So now it is back to being configured as it was, and my settings on the EX are:

This outputs DSD256 with no problem, but stutters on 512 on just about every combination. I guess this is just a limit of the EX…

It can be helpful to check CPU usage on the device running HQPlayer. That may be the cause if the stutters.

The value that “localhost” returns is the IP address of the machine it is running on. Since I have HQPlayer running on the same server as my Roon Core, this works for me. The advantage of using “localhost” is that if the server’s IP changes, there will be no need to update it in Roon.

I may have more to say later.

Thanks Kenny. After spending far too much searching on the internet (I need to get out more!) I found this thread of someone asking the same question regarding the cutting off of tracks when using the sinc filters HQPlayer "cut off tail of track" issue fix - Feature Suggestions - Roon Labs Community