Anyone else out there using HQPlayer through Roon?

Thanks for our help. I’ve had a think and will buy a laptop to run Roon and HQP. It’s worth setting my system up to be able to delve into the full ‘power’ of HQP, without there being any limitations in the chain.

I need to get my head round the optimal specs that this laptop will need. There is some information on the Signalyst website, and I can also make enquiries on the Audiophile Style HQP thread.

1 Like

Sorry, forgot to ask. How will the connections work? Seem to be two possibilities:

  1. New Windows laptop with Roon and HQP Desktop is connected to my router using Ethernet cable; and the laptop is connected to the K22 presumably by a USB cable.

  2. K22 is connected to the LAN (i.e. my router) via Ethernet cable, as it is at the moment. The new Windows laptop (with Roon + HQPD on it) is connected to my LAN via WiFi, but is not physically connected to the K22. I’ll continue to control my music using the Roon app on my iPad.

Option 2 seems more correct to me: is that right?

I’ve never seen the Antipodes dashboard when just a single server is used. Can Roon be set as server and HQPlayer as Player? If so send a screenshot then we will go from there.

I’m currently using Roon Auto as the Preset, but hopefully this screenshot helps answer your question. On the left hand side I’ve dropped down the Player Settings box, and you can see HQPlayer NAA listed as an option. On the right hand side you can see Roon listed as an app under Server Settings.

That’s really helpful, thanks.

What you should try:

K22 and laptop both connected to your network with wired Ethernet.

K22 runs Roon as Server and HQPlayer NAA as Player.

Laptop runs HQPlayer desktop. HQP should be able to find the K22 NAA. HQPlayer then is set to output to it.

Roon is then configured to reach HQPlayer via the IP of the laptop as instructed here:

You mentioned having the laptop on wifi. That might work but the signal strength needs to be excellent. Also, if the IP address of your laptop changes, Roon will have to be reconfigured. Best to reserve that IP in your routet configuration.

That’s great, thanks. I’ve read info today on Audiophile Style and other threads that you need some hefty CPU and GPU power to be able to use all the HQP filters etc. Optimal Intel CPU would be an i9-12900K. I haven’t yet worked out the best GPU, but latest gen GTX-xx70 was suggested somewhere, and also 3060ti or 3070ti as ti cards have more CUDA cores than non Ti cards.

This may be overkill for much of what HQP can do, but it seems best to have a laptop which can deal with anything that HQP can throw at it. Both now, and whatever it evolves into in the future.

I have yet to establish what such a laptop would cost…

Actually what I may do first is have a play around with Squeeze plus Qobuz instead of Roon plus Qobuz. I’ve read some good things this evening about Squeeze……


I’ve finally tried this, but I’m not sure whether the K22 can do it. I put HQP Desktop on a fresh Windows 11 laptop, which is connected to the same network as the K22. I set the K22 for Server = Roon and HQPlayer NAA = Player. I set up HQP in Roon - Settings - SetUp with my local IP address (not localhost). In HQPD the Allow control from network switch is toggled on.

However as much as I fiddled around with the Settings in HQPD, Roon was unable to find HQPD to output to it (this is using PCM, not DSD).

In HQPD Settings there is a box for Output Device Settings, and the options for Backend are WASAPI, ASIO, NetworkAudioAdaptor, Network Audio Adaptor IPv6, and Null.

For Input Device Settings the options for Backend are WASAPI, ASIO, NetworkAudioAdaptor, Network Audio Adaptor IPv6.

I’m not sure which of those I should select for this situation, but I did try a number of permutations and none of them worked.

If you have any suggestions on how to get this to work then that would be great. Otherwise I’ll try the approach suggested by someone on Audiophile Style, which is to have both Roon + HQPD on the laptop. But I’d prefer not to do this unless there’s no alternative.

I will play with this myself here and let you know what I find. Give me a few days.


I think I’ve sorted it. You mentioned a few weeks ago about reserving the IP address in the router, and this is the key. I logged into my router, and fixed the IP address of the laptop which has HQP Desktop on it. That’s the IP address I used when setting HQP in Roon, and so far it’s working. …

1 Like

Hello. I would also like to add my experiences with regards to using the HQPlayer. I tested the HQPlayer with the Roon Server. I tested pass through and some many filter options. So I would say that the HQPlayer in conjunction with the Roon Server sounds rather soft and full-bodied. Difficult to explain. So Squeeze (Auto) or Roon (Auto) sound significantly different without upsampling or, in other words, Bit Perfect. For me it’s the most honest. Even pass through under HQPlayer sounds rather too soft. HQPlayer also sounds the quietest of all players. Bass is also rather soft and less powerful. HQPlayer still sounds OK. Maybe you should test the HQPlayer (Auto) on its own. HQPlayer Server/HQPlayer Player against Squeeze (Auto) and Roon (Auto). My DAC, the Merason DAC1-MK2, is actually a NOS DAC. He jumps at the sound changes, but whether everything is right and sounds right, who knows. Can someone tell me whether you can exclude/deactivate the 176.4 Khz sample rate in the HQPlayer settings? My Merason cannot play 176.4 Khz. Synchronously connected to the K50 via AES/EBU. The HQPlayer always uses 176.4 Khz for its filters (when set to Auto). The maximum resolution of my DAC is 192 Khz. Under Roon Settings I can specify/set it to be user-defined. But I don’t want to activate upsampling in Roon and then send it to HQPlayer. I could always set the sample rate to 192Khz output in HQPlayer, but I don’t know if that’s always correct. I also tried @kennyb123’s setting. But there is no sound coming out of it for me (LNS15, Sinc-M…). My Merason doesn’t process DSD.

That’s because startup volume is set to -3dB. This is recommended as additional headroom is needed when upscaling so there aren’t “intersample overs” when reconstructing the wave form.

If you uncheck auto rate family, everything will get upscaled to your PCM rate limit (192000).

1 Like