Cannot "see" network NAS files in Squeeze library

Hi – I do all my playback on my K50 from SSDs that are in the back of the unit. I also have a Synology NAS on my network that serves as a backup for the files. I am interested in hearing how the files on the Synology sound if they are streamed directly from it, rather than the SSD playback. However, when I went into the server settings in Squeeze, only local folders on the SSDs show up as available for importing into my library. Nothing from the network, including the NAS, is visible. Network folders, including those on the NAS, are visible in Windows Explorer. I’ve tried fiddling with the permissions settings on the Synology NAS, but without success. Anyone have any thoughts? Thanks. – David

The connection to network shares is made using AMS. Scroll down and find the paragraph that begins with “You can include music files that you have on your NAS” in the guide here.

You can use the AMS File Manager found on the Server dashboard. To include/exclude shares from your NAS.

Kenny, once I got to my server dashboard on AMS, I selected the “Include Files” tab, and got a pulldown menu asking for SMB Share Path, SMB User Name and SMB Password. I had hoped that the user name and password would be the same ones I use to access my Synology NAS, but apparently that is not the case. I get error messages. I have managed to enable SMB in Windows 10. But when I google something like “finding SMB username / password in Windows”, I get more IT gobbledygook than I can process. Anything you can think of to get me past this final step would be gratefully appreciated. – David

Yes it is the same user name and password as your Synology NAS. What I recommend is using the IP address of your NAS instead of the name when specifying the destination.

If you get an error with this, please share the error message.


Ken, thanks so much. I’ll give it a try.