Can't play 24/196!

I just got my K50. I use MSB Premier DAC and Nordost Valhalla 2 XLR. I use Roon. I can’t play 24/196 either from streaming or K50 hard drive, but DSD64 works well.

Any Ideas what to do?

Hi - Do you mean 24/192?

Yes off course! :+1::+1::+1:

I believe that’s the max PCM sample rate when using AES. See the K50 specs here. You will need to use USB to go beyond that.

It’s 24/96 that’s not working.

Stange - my CX with 3.13 can play any format i throw at it through roon.

That’s most likely a software issue. Please post a screenshot of your signal path when playing 24/96.

This is what I mean by signal path. I don’t expect yours to look like this but I just want to see the path it’s taking when you play 24/96.

24/96 is not workin, 24/192 is not working either. The multiple of 96 is 192. Is there a connection?

24/176,4 works well as 88,2 and 44,1…

I’m now quite sure that my new DAC has got some problem with the clock. K50 is probably not the problem in this case.

The clock is provided by the K50 when you use a synchronous output. There could be an issue with the K50. The word clock should support multiples of 44.1k and multiples of 48k. It sounds like the latter isn’t happening for some reason.

If your DAC can play multiples of 48 when you use USB, then the DAC is probably fine. USB is asynchronous so the DAC’s clock sets the agenda.

Maybe check the sample rate conversion settings in roon. To get to DSP setting, tap the speaker icon at the bottom right, tap DSP.