CX network connection problem

My Antipodes CX periodically loses network connection. Antipodes Version AMSv3.12, Roon 2.0.I was really tired from this. On version 2.7 CX worked stably but two weeks ago it stopped connecting to the home network or after connecting it loses it. The device is connected to the Linksys router and then to the English Electric 8Switch network distributor with Synolojy 418 NAS . The End point is DCS Vivaldi Upsempler. I tested my network and network units two days ago by service company. Everything was OK but problem was not solve.The network device physically loses connection with CX. I see it on my computer. No reboot combinations help. All network addresses are fixed on the router. Only the connection with the CX is lost. Everything an other DLNA devices work stably.

Is the CX pingable when this occurs?

One thing you can try to help with troubleshooting is to shrink your network temporarily. By this I mean have only a single cable between your CX and the router. The goal is to rule out something other than the CX as the cause.

No, CX is not pingable. I reduced the network to a minimum. I connected the computer, CX and router by wires without WiFi. It was the same.
I noticed one interesting moment. I have EX. He behaves absolutely exactly the same. I connected it to a reduced network - Linksys- EX-Macbook. It was also unstable. I saw it periodically falls off the network. One more. Connecting EX to the network while Roon was working dropped as soon as I tried to connect to Roon from the iPad via WiFi.
IPv 6 have been disabled.

That suggests the network is the cause. You mentioned the addresses are fixed. Have you also excluded the fixed addresses from being assigned via DHCP? Some routers do this automatically but others do not. You seem to understand networking well so I apologize if you already considered this, but conflicting address assignment can result in what you described.

What I have done with routers that don’t do this automatically is only fix addresses outside of the range that DHCP uses. So DHCP might start at but I change the start to like That then leaves me with the ability to assign fixed addresses from to with no risk of two devices vying for the same address,

Thanks for the help! I separated fixed addresses and DNSP. Now I can load my CX but it behaves some weird. The biggest problem was when I uploading after completely turning off the power on the rear panel of the CX or an emergency shutdown. Now, after turning on the power, the green indicator on the front panel is immediately start by blinking. About 30 seconds ago it turns green but the CX does not see the network. I can see this clearly on switch. Network indicator on the swtch is yellow. I shortly press down the green button on the front panel and it starts flashing again. After a while, it lights up orange, then flashes again, and only then lights up green a second time. The switch indicator also lights up green. About a minute ago, CX appears online. I’ll be watching for a couple of days.

Maybe, just maybe, it could be ipv4 or ipv6 setup. Antipodes might not be accepting ipv6 adresses. You could check your network settings. If possible, try ipv4.

Hi Kenny, you seem to be a network expert, so I would appreciate your advice. ISP has annoyingly sent me a new hub. Before I had 100% reliability, now I am getting issues where playback through Roon and HQP doesn’t work. Restarting HQP in AMS on both server and player seems to fix it but that is a massive PITA.

Have you got any recommendations of particular settings to check in the hub settings? The CX is currently connected to the hub via an ethernet socket marked as 2.5 Gbps. Is that a bad idea?

It should auto negotiate so this is ok. Please post your HQPlayer configuration.

Please make sure IPv6 isn’t enabled for HQP. Your new router might be introducing this.

Thanks Kenny, It seems to be working fine lately, so maybe it took some time to stabilise after the new router was installed.

1 Like

Hi KennyI wrote to you 16 days ago. Nothing helped me. The network connection is extremely unstable. Yesterday I changed the router, but that didn’t help either. Apparently the problem is in Antipode. I found two MAC addresses of CX in my network. The router uses 08:60:6E:FE:13:2F with the address May Atipodes CX
determines the offline address 08:60:6E:FE:A4:DB.

A stable connection to the network occurs spontaneously and can disappear at any moment. To exclude all extraneous influences, I assembled a short wired network and experimented with it.

There are two ethernet ports on the CX. Each one will have its own MAC address. Do you directly connect one of the them to the EX?

Yes, but now I use CX only. One of them I connect to router and an other connect to DCS Upsempler.

If you are overly taxing the CX with HQPlayer, it may be overheating and temporarily shutting off, check temps to be sure, as well as CPU usage

I have already noticed that address loss sometimes occurs after using CX for some time. I use ROON. The main problem is get the initial network address after connecting power of the server. Sometimes this happens quickly within a minute. Most often, CX tries to get a network address for quite some time. The LED on the front panel blinks green, then stops and resets the connection again. I can observe this yellow-green illumination for about three minutes. If after this time CX is no connection to the network, then the CX may blink for hours!!! The same thing happens after losing connection to the network during a work. As I wrote earlier, when the CX power was connected, the indicator turned orange. Then, after briefly pressing the button, CX blinked and turned green after connected to the network. This is not happening now. When the power is connected, the lamp on the front of the CX immediately blinks green and stops blinking after about 30 seconds. When this happens, there is no connection to the network. I see this through the indicators on SWITCH and CX. After briefly pressing the button on the front panel, the CX tries to connect again and then depends on luck.

Sounds like several things are at play here, if your device doesn’t start to solid Green, then it needs a service, or it cannot say hello to Antipodes servers over the internet or both, this would indicate perhaps a router, ISP, or DNS issue, where are you located?

I am in Russia (Vladivostk).I brought the CX from Montreal, Canada. The first launch of the CX was normal. This problem appeared after some time.

Book a remote session so we can check/update software and see if we can locate any issues with the CX

What remote access program should I install? What time is indicated on the schedule, local or Vladivostok time?

If you have the time set on your computer it should be your time, we use AnyDesk, instructions are sent when booking, but see this post…