DX2 no longer accessible

Hi guys.
My DX2 running V2.7, has decided not to make itself accessible. I leave it permanently on.
I have installed a new router, but I believe the DX2 IP was DHCP so should have received a new address. Regardless I could not access using its original IP from a computer set to that network either. Launching from myantipodes has never worked with this device.
I tried to reboot a few times - but it would not turn off via the switch on the front panel.
I eventually resorted to turning it off by the rear switch, left for a while and then turned on again. I still could not access either via its IP address or via Finder in OSX.
I repeated this process a few more times and eventually it would respond to turning off and on via the front panel switch.
I rebooted a few more times and then it appeared in Finder. After a couple of more goes I could access the usual folders and music files. However, I still cannot access it via a direct connection from Roon, my laptop direct or from the network.
Any thoughts gratefully accepted.

One of things to do is to also re-boot your router, this generally has the desired effect in fixing network related issues.
It is also worth checking the Roon Knowledge Base, to ensure your devices are on the same sub-net.

Thanks Mark. Turns out that it was one of my modem/routers on the way out! Replaced and now all good.
Thanks for your reply.

Awesome, well not awesome, but pleased its all sorted :slight_smile: