EX not recognised after update or cable swap

This morning I updated both my DX3 and EX.
Then the same phenomenon happened as I ran into of late. I hoped the update would help, but no.
FYI: in my set up the DX3 is the server, the EX the (Roon) player connected with a Mola Mola DAC through USB.
On both the EX-board and in Roon (set up) Squeeze is installed. (On EX: Squeeze from Roon)
Now here’s what happens every time when the AP devices have been disconnected (either the interlink, or current is interrupted), Roon doesn’t show the EX any more in ‘Audio’.
I discovered lately that I can restore the connection by switching back to bare Roon on the EX board. Then Roon recognises the EX and I can play Roon. After that I switch back to Squeeze (from Roon) on the EX board (and in Roon: Squeeze activated), which is a breeze.
But the odd thing is that it appears to be the only way to play through Squeeze.
I guess three must be an easier way to solve this.
Most obliged with some advice on m this issue.

The easiest way is to toggle the “enable Squeezebox Support” button in Settings/ Setup in Roon on and off.

Ok, as simple as that….
Odd still, that Squeeze inRoon first has to be reset before the EX can connect to the DAC, is it not…

Using the EX Solution Dashboard to manage both DX and EX.
The DAC has to be “seen” or set here first, this is where all adjusting to apps and dacs should be made, prior to launching the app.

hi Mark,
since I had to do some adaptations in te network today I ran into the sae when,oneon I described. then applied what you suggested. so sorry to tell you it didn’t work.
Connecting the EX to Roon/making it visible there remains somewhat complicated. as I described.

  1. I first have to toggle the Squeeze mode in Roon audio settings to unable it
  2. then reset the EX dashboard into Roon instead of Squeeze through Roon
  3. then switching on the EX in Audio in Roon settings
  4. then go back to the EX dashboard and re-install Squeeze through Roon
  5. then back to Roon audio settings and toggle Squeeze back to enable.

Rather complicated and time intensive. There should or must be a workaround, but I can’t find it…
If you have a clue, I would be most happy with it.


Thats not right, please set up a time for remote access support here…

Also the instructions for remote access software here…