HQ Player Playback Failure in Roon

Sorry if this has been posted here in the past, I did a search didn’t find much. I was curious to listen to HQ Player so I downloaded the trial version and added to Roon, watched video on Antipodes website and followed directions for HQplayer. I continue to get the playback fail message in Roon (see screenshot).

My set up is as follows: internet>>Ethernet>>Gigafoil/Ethernet into>>K50 AES into>>MSB DAC>>Amp.

What I am likely not understanding is the setting between Roon and HQ player. My backend is set to ALSA but only giving me the option for USB output and I am using AES. Is this the issue? And does HQ player only work with USB. Makes sense I suppose since I can’t upsample on AES?



Backend should be Network Audio as it is the Player engine in your K50 that talks to your DAC.

Also, the PCM rate limit is too high for AES. Set it to 192000. And enable auto rate family.

1 Like

OK I changed those settings still not working for me. Here are some shots of the Player Software itself. Is there a setting there I am supposed to change as well?

Sorry for all the questions I feel like I’ve trouble shot this enough on my own by just switching what ever I thought would make it work…With no success.



It just struck me that your problem is likely due to you running it in trial mode. You actually have to restart HQPlayer on the Server apps page each time you reach the trial limit.

1 Like

Yeah I thought of that and rebooted everything and it didn’t seem to shakes hands with the HQ Player. I will try again tomorrow. Definitely getting frustrated…But now might be a good time to consider why I am doing this…Is the sound quality better with HQplayer over and above Roon player? I likely won’t be listening to alot of DSD tracks since I am on Qobuz.

Use HQPlayer only if scaling benefits your DAC. Since are using AES, you won’t get much advantage from scaling, so I’d suggest going with Squeeze or Roon player.

Good suggestion. I am on a Mac so not sure I can use Squeeze. I may try the USB with my DAC just to play around with the scaling. Waiting on a a new USB cable to get that going and make some comparisons. To my ear so far AES sounds better than USB so this will be an interesting test.

If you mean you will control playback from a Mac, yes you can. All you need is a browser.

1 Like

Ok I need to research that…Clearly I am realizing I am an idiot the minute I decided to leave the safety net of Roon. Weird what these audiophile brains of ours will have us pursue. Roon sounds perfectly fine, but I won’t be satisfied until I satisfy that curiousity!

Well I got Squeeze up and running…Definitely and audible difference over and above Roon as a player. Still can’t figure out HQPlayer, will keep trying. Maybe I need to just buy it and remove the trial.

Ok so I am eeking my way through this…Got it to stop giving me that error. Now it “appears” to be playing when I hit play, time is NOT advancing it and the K50 indicator appears to be moving along as if it were playing. No sound coming out. Are there step by step instructions on how to set this thing? Has to be an issue with my settings.

jamtown, did you get this sorted? I have the same trouble playing K50 into MSB Reference DAC via ProUSB.

This sounds like the behavior in trial mode. On the About tab for HQPlayer, does it indicate that you have a license? If you see the word trial, then you have to restart HQPlayer to get it to work for another 30 minutes. Then rinse and repeat.

Just to answer my own question, above:
I found that I needed to program HQPlayer more than once (both “ALSA Backend” and “Network Audio” needed to be set to the ProUSB setting) to make it work. Then it worked.