HQ Player stopped working

Thanks, I got as far as getting the play list but pressing play does nothing. Far too complicated it seems. It seems to cause instability with the Roon HQP link so I will stop faffing with it for now.

HQPlayer exposes a very simple API that allows other programs to control it. Both Roon and HQPDcontrol v4 app call this same API. One cannot really harm the other. What they can do is confuse each other momentarily. If Roon thinks it’s been playing track #1 but HQPDcontrol v4 is actually playing track #2, Roon will have to seize control back next time it’s used. There might be a momentary hiccup, but once the baton has been passed Roon is in full control - at least until HQPDcontrol v4 tries to take control again.

From the perspective of computer operation, this couldn’t be simpler. And that’s why the HQPDcontrolv4 app can seem somewhat quirky. It has only a handful of commands at its disposal. The commands pertain allow it to retrieve the list of albums and tracks from library, manage the queue, and manage playback.

Playback with HQPlayer is always based on what’s in the queue. The first step is thus to add tracks to the queue. Then once in the queue, playback can be started or stopped. HQPDcontrol v4 makes this super easy as when you browse the library you can directly play an album and this clears the queue, adds the album to it, and then begins playback. Alternatively one can click on the three vertical dots and a menu pops up allowing one a number of options. Once the queue has been populated one needs to switch to the playback interface. If you look at the top right, it is the second icon from the top right that one must click to get to this.

This UI has always worked for me if HQPlayer is properly configured. In fact, this provides one of the best ways to tell if HQPlayer is properly configured. If clicking play doesn’t cause the track to play, there is something wrong with the configuration.

Thanks Kenny. I tried to google the solution. There is some mention of the need to allow remote access for HQPD v4 to work. I looked at all the available settings for embedded HQP and couldn’t find this option anywhere. My Roon solution is working for now so interest in getting the HQPD v4 working is fading rapidly.

Edit - tried HQPD one more time, and it works!
Perhaps the reason it didn’t work before was the same issue that stopped HQP working with Roon.


For future reference, the developer of HQPD monitors this thread:

1 Like