HQ Player stopped working


I upgraded to 4.1 recently.

It has been working fine for a few days. I am using Roon and HQ Player on a CX/EX.

Today I tried to play something and nothing happened. I just got the purple histogram jiggling around on Roon, but the track never started playing. No error messages.

I opened the antipodes interface and checked that HQ player settings and could see that the license key was valid.

I changed the solution to Roon and I can play music. When I try to switch back to Roon plus HQ Player I now get the error Roon can’t connect to HQ Player!

Any ideas? This is quite frustrating. I never had any problems in the last OS.

“Playback failed because Roon couldn’t connect to HQ Player”

If you restart HQPlayer from the Server dashboard does it begin to work again?

Tried that. No joy.

Also tried restarting CX and EX. It actually worked for about 10 seconds, then playback stopped and I get the Roon can’t connect to HQ Player error message again. Bizarre.

Can you play a track using HQPlayer without Roon?

No idea how I would do that. HQ Player embedded has no front end.

Not so. Just have it scan a folder and albums should appear. It could take a long time to scan your entire library so just pick a single folder.


didn’t know about that feature, will try tomorrow. 99.9% of my listening is from Tidal but I do have some local files.

Or you can download the app HQPDcontrol v4 for operation

1 Like

As mentioned on head-fi, did you restart the naa on your player?

I restarted both CX and EX machines. It worked for 10 seconds and then failed again. I will do more testing this evening.

I tried restarting NAA on the player - made no difference
I tried restarting HQ Player on the server - made no difference
I tried playing directly from the HQ Player app - it works! Only problem is that the app only has a button to start playback, no button to stop!!!

I tried the HQ Player control app on the ipad. Couldn’t figure out how to get the library to appear. The app looks like a high school project from 20 years ago.

It seems like there is a problem with Roon talking to HQ Player which is very disappointing.

Mark, please let me know if there are any other diagnostics I can send to help resolve this. I did update the Roon remote app yesterday in an attempt to fix. The problem was happening before and after the Roon remote update, so I don’t think that is the problem.

Managed to get the library to appear on the HQ Player control app by entering the IP address of the CX as the host. I couldn’t work out how to play a track. Clicking on a track does nothing.
In the settings I see you have to specify a port number. I have no clue what to enter here.

This app is interesting as a backup plan, but top priority is to get Roon working again.

It sounds like you got music playing with HQPlayer. That’s great.

Now in Roon, go Setup under Settings. What do you see for HQPlayer?

As @kennyb123 mentions, above, enter the IP address of your HQPLAYER server here, which is the CX.
This will likely create a new entity in the Roon Settings Audio section, if you have previously set up a non working “zone” it should be deleted.
In HQPLAYER setup, ensure under Generic that Backend is set to Network Audio and Output Mode to Auto.
As you go down the setup page ensure the sample rate for PCM does not exceed that of the DAC you have connected.
Scroll down to Network Audio Backend, ensure that the correct output is selected for the EX.

For HQPDcontrolv4 in the menu you have Auto Discovery of HQPLAYER and Syncing the HQPLAYER library buttons. Once your HQPLAYER is discovered hit sync library.
To play select an album, in the three dot menu at the top for options, once playing if you pull up the tool bar dirs,
artists, albums etc there you will find the start stop next etc which is the now playing screen.

More than happy to hop in via remote to assist if required.

1 Like

Thanks Kenny and Mark.

I eventually got it working. I ended up deleting the HQ Player audio sources in Roon and reconnecting. Then I did a reset NAA on the player side.

I don’t know what caused this. First time I have had any problems in 2 years.

1 Like

I am still baffled by the HQPD control v4 app. I successfully synced my library. I clicked the three dots to play the album but nothing happens.

When I click Autodiscovery in the menu I get a message ‘not implemented’.

Curious to try this method because I suspect the sound quality will be better than Roon. The sound was excellent when I played from the HQP Library screen, but only having a play button and no stop or skip buttons is highly inconvenient!

It is a bit of a thing tbh, I just tried to reset mine back up and auto discovery of server didn’t work.
I entered the IP address of the server.
Then clicked sync library.

Also ensure that your library path is entered in HQPLAYER

Click an album to open it, click 3 dots at top to get add menu

Pull up bottom tool bar to reveal the player

Swipe to the side to see queue

1 Like

Same thing happened to my HQ player yesterday and just seemed to need rebooting up —- Was like it lost connection. —

Interesting. It has happened to me twice now since upgrading to v4.1. The fix is to reset HQ Player on both server and player.

The second time was after faffing around trying to get HQP control v4 working, so perhaps that caused some instability. I will leave it alone for now to see if the problem re-occurs.

The symptoms are:

  • start playing a track, purple histogram jiggles around in an endless loop. The usual behaviour is for the track to play after 5 seconds buffering.

  • The ‘Roon could not connect to HQ Player’ error was a user error on my part. I initially deleted the wrong HQ Player endpoint from Roon and was trying to play to an old version when I had HQP on the EX.