HQPlayer embedded no longer working

If you are having HQPlayer issues, please book a Remote Access Support Session

I have mentioned several times before my preference for PGGB over HQPlayer. The developer of PGGB recently posted a chart that offers some insight into how upscaling benefits. This applies just as well to HQPlayer, as it aims to these same things. The text that’s in white is the best explanation I’ve yet seen as to what is likely going on with this stuff.

The goal is to push noise way outside of the audio band. But what’s interesting about it is that the noise that’s outside the audio band, while not audible, can cause interactions that are audible as per #2 in the white text. You mentioned hearing an etch and sharpness. I think that is likely the result of your chosen filter creating problems for your gear. If you are using AES, it could also be that it’s being pushed too hard.

What I find most fascinating is that many PGGB users (including myself) can hear clear differences between the three filter choices shown in the following chart. That’s crazy when you consider how low the noise is in each of these. I think that may also speak to the K50 having such a low noise floor itself.

I had the same problem on the EX. Marc Cole fixed it remotely.

1 Like

Had a Remote Access Support Session with Mark yesterday evening, and this was fixed within a few minutes.

1 Like

Just did the update and I also am having a Hq player problem. I have paid for the Hq player so this is not the trial version After all other updates the Hq player just needed to be reopened — after the update Hq player was not being recognized on my roon server — Went to solution board of my antipodes and it came up asking for a user name and password which I have no idea what they are — any suggestions

The default user name and pass are admin / admin

Well I now can get into Hq player but when I go to the Key section and try to download my license key it does not download any thoughts?

You were sent the licence key by Signalyst, you need to remember where you saved the .xml and upload that in the licence key tab

I have the downloaded key and when I try to install it on the key page of Hq play nothing happens ( it say wait 10 sec ) and nothing happens does not show the downloaded key zero Any thoughts ?

I assume that the Antipodes has been rebooted after update, try restarting HQPlayer to see if the trial period had expired, log back in with admin/admin, and upload key

Pleased to say a support call sorted my issue, many thanks for this. Resolution was a complete re installation of HQPlayer server and NAA. No clue what caused the problem in the first place though so just hope it doesn’t happen again.


Famous last words. It worked for a few tracks last night and went to bed happy (thank you support). Tried again this morning and all was well for a couple of tracks trying different filters, and then received ‘roon cannot connect to hqplayer’. Thinking it was the trial account timeout i went to the AMS solution dashboard, selected open…no credential screen asked for, went straight in to HQP settings. I applied twice, closed, went back to Roon, no effect. Restarted everything - HQP Server first then Roon Server, removed Roon HQP zone, readded zone (tried localhost and IP address), restarted roon server again, opened HQP expecting to be asked for password, nope, straight in again. I did look to see if the credentials screen was hidden, nothing.

After perseverance, credentials were eventually asked for again and although i entered them and applied, still same issue. This has to be an authentication/hqp server issue. My iPad started to report server not found after applying HQP settings which is something i had experienced before.

If someone was able to say they are using Roon with HQPlayer fully licensed with no issues that would be a big confidence booster. What i dont want to do is purchase the full license and find i have the same problems, it is non returnable.

Will book another support call…

I use hqplayer and roon fully licensed with no problems. Try turning off power to your modem/router to reboot it. Sometimes clearing the routing table helps.

Usually, all you need to do when the trial license times out is to restart HQPlayer from the Server dashboard. Occasionally one will need to just resave the configuration, but you should never need to change the Roon HQP zone after the trial times out.

Trial mode was terribly implemented on the embedded version of HQPlayer. It’s only intended to allow one to determine if they like what they hear enough to purchase a license. It’s best to use it standalone to make that determination (in other words, without Roon). I honestly think that the only way to give HQPlayer a fair shake with Roon is to have it fully licensed.

HQPlayer operates without issue as long as one applies a license and then one sticks with a configuration that works. The license might have to be reapplied after Anipodes updates AMS but otherwise it should just work.

The credentials only serve to allow you to access the configuration page. They play no role in playing back music. Your browser should have asked you if you wanted to save the credentials. If somehow you skipped this step, you will be asked to provide credentials each time you visit that page. I think if you clear the browser cache, you may get asked again if you want to save the credentials, but it depends on which browser you are using.

Thank you all for clarifying. Your comments have given me the confidence to proceed to full license. My feelings were focussed on the trial license being the issue. Apart from reboots and restarts of servers and backend devices I did also reboot router and switches and cleared cookies etc.


For info to others, I had a further support call last night. Actions were to completely restore all software and apps. This meant losing Roon settings and restoring a backup later.

I now have a full license and this was applied. Hopefully not jumping the gun but all seems to be working ok now however -

  1. Applying the license could be more visible. Yes it does give the licensee in the about page, but something to say one has been applied on the Key page would be useful.

  2. I have still been asked for password and user (as per trial license) which doesnt make sense to me. I would have expected to have had to change this to my own user (or one supplied with the license). Small point but just a little confusing.

  3. Probably me and not having extensive use of HQP but if you select a filter and choose a sample rate that isnt supported, Roon playback will not start and no error is shown. Only when you look at the HQP log file will you see an entry re ‘unsupported sample rate’. Just one to note for those who have come across play not starting in Roon using HQP - check the HQP log file. It would be nice to have only supported rates shown when you selct a filter but with the almost infinite number of combinations and capability of your player i can understand why this isnt the case.

I have a long road to go with HQP in use, just hope i dont have any more hurdles in the way of my progress.

Thank you once again to Antipodes Support, fantastic service and much appreciated.

1 Like

I’m also having this problem. I rebooted k22/40 and hqplayer still showing as trial.

I don’t know if this is the problem but when I open the Key in Notepad it does not disclose my name properly because it does not recognize the apostrophe. If I open the key in MS Edge browser it discloses my name correctly with the apostrophe.

When it shows trial, the fix comes from again uploading the license key. If it’s still showing trial after that, it’s likely something caused the fingerprint to change from the value it was when the license was purchased. Jusssi will reissue the license at no charge if this has occured.

I already contacted Jussi. He said it was because the embedded version is 4 but the purchased key is for version 5. He is meant to send me a key for version 4 but that is yet to arrive.

1 Like

I received a v4 key and everything is working now. HQPlayer via Roon does sound better than Squeeze. Squeeze is a little too relaxed, HQPlayer has lower noise floor and better tone texture.