HQPlayer embedded no longer working

Have had a look round the support forum but cant seem to locate a similar issue being raised. I have used the preset for ‘HQPlayer with Roon server’ on my CX for a few weeks with no issues at all. At the weekend i settled to have a listening session and Roon couldnt find HQPlayer. Selecting a track resulted in the Signal Path icon in roon changing for a split second and then greying out. No error displayed by Roon until play pressed again then ‘Playback failed becuse Roon could not connect to HQPlayer’ was displayed.

I went through the usual reboots, restarts, removing HQPlayer from Roon, re-adding as localhost (as it was before) to no avail. There have been some recent updates to my HQP NAA, SoTM SMS200 Ultra ES, but all was fine after that update so i cant relate the issue to this. Upgraded to AMSv4.31 some time ago and Roon+HQP has been working since so not that either.

One other strange thing, when tring to Apply changes to settings in HQP on my iPad via Safari i am now getting the usual success please wait 10 seconds, but then ‘Safari cannot open the page because it could not connect to the server’ error, something that never happened before. Refreshing brings the configuration page back. Appears to work without this error on home PC using Chrome.

The trial license for HQPlayer states it works for 30 mins and needs a restart, which is something i have been doing but i have noticed now that the frequency of having to log back in doesnt make sense since my issues started, i noticed yesterday that i wasnt asked to input the credentials at all, even after restarting services or rebooting the CX. I have had a look at Roon and HQP log files - not the easiest to read if you havent got a clue what you are looking at! However the following seem to indicate that Authentication is ok, i even changed the password from admin to something else and back again to force credentials to be asked for.

03/01 12:03:23 Trace: [transport] [hqp/auth] Authentication Complete
03/01 12:03:23 Trace: [hqplayer] [localhost] Connected
03/01 12:03:23 Trace: [transport] [hqp/client] [localhost:4321] SENT

Further entries indicate disconnection but nothing logged around this jumps out as a reason to me. Whole log for playing one song lasts under 2 seconds.

No other network changes have happened (that i am aware of) and HQP is showing the SoTM NAA Backend as expected. Even played with IPv6 on and off for all devices and nothing. I am at the limit of my techincal knowledge now so some help would be appreciated.

For info, Roon works fine without HQP embedded.

It did occur to me one possible reason may be HQP trial only lasts for a fixed period or fixed number of log ins, i cant see anything in the Signalyst web site or forums to this effect. By this stage I was already tempted to buy HQ Player license but would like to confirm there isnt anything more sinister going on first!

Any help/suggestions appreciated…

Trial mode is time-based and once the time is exceeded, HQPlayer server needs to be restarted. I think it’s like every 30 minutes so be sure to go to the server dashboard and click restart to get music playing again.

Hi Kenny, thank you for replying. Yes thats what was happening when all was well, i had to relog back on to HQP after 30 mins. This isnt happening now, prompt for password is no longer being shown even after 30 mins, it just goes straight into the config page. Changing the password and then changing again back to admin does force the credential prompt to be displayed again but only once. This one is really strange. Wonder if i need to remove and reinstall HQP on the CX, is that possible? Just cant understand why when all was working ok it has just suddenly decided not to :frowning:

Have you tried restarting HQPlayer in the Server Tab of the dashboard?
Are you using the CX as server/player?
Book a remote session we can take a look if required.

Hi Mark, yes i have tried restarting HQP on server and also restarted HQP service on SoTM SMS200. Even restarted Roon after removing HQP zone and again after re-adding, basicaly anything restartable i have tried. I am using the CX as a server and SoTM as NAA backend. I wil give it another bash this weekend and will book a session if no joy. Many thanks for your reply. Just cant understand why it would suddenly just stop working. Server activity is showing as low on dashboard so doesnt appear there are any rogue processes.

Are you entering the IP address of the HQPlayer Server into the Room setup.

Leaving that as localhost, have tried the CX ip address as well, even with the port extension in the HQP log file. localhost was working fine.

Couple of things that dont make sense. First is when removing HQP from roon and re-adding, if it was totally removed how does Roon then name the HQP zone the same as it was before it was removed, surely a full removal would mean having to rename again? Wondering if some settings for Roon HQP arent being totally removed/updated in the background as they should be.

Also when restarting HQP embedded, trying to recall correctly, i think when all was working ok restarting resulted in having to re-enter login credentials again, that is not the case now. This one could just be me using memory to look for answers…

One other thought that may just be coincidence, i applied the upgrade to AMS4.31 and the HQP problems indicated seem to have started on or around that time

Roon “knows” because the IP address of the HQPlayer server has not changed, if the IP address changes you will need to set up the audio again in Roon.
For a two computer setup, we would recommend using IP address for the server in Roon.

What version of NAA is on the SOTM?

Hi Mark, seeing something not clear is sometimes an alarm bell to say previous settings havent cleared correctly but if this is expected behaviour its another potential for me to cross off the list :slight_smile:

Tried the IP adress and again no luck. SoTM HQP NAA version is 4.3.0.

Had yet another go at clearing everything down, even reinstalled Roon last night. Roon via RAAT is working fine to both wired and wireless devices (so Roon and Qobuz account are ok), it just seems that Roon cannot connect or is being denied connection to HQP.

Just to confirm again i am using the HQPlayer with Roon Preset on the CX

Hope this may mean something. Log for Roon when trying to play a track after full restart of HQP and Roon Server on CX. All seems to be ok in report logs (from my limited knowledge) until just after Signal path where hqp/client reports disconnected. Also interesting that in signalpath info it states rate = 0, all other settings are as per expected but rate should be 256000 for this test. Also note that all this took 1 second. Signal path in roon control app on iPad and PC does change colour so info must be getting through, but only for a split second before stopping. HQPlayer is reporting the NAA backend as SoTM/Denafrips as expected.

03/03 10:03:45 Trace: [transport] [hqp/client] [localhost:4321] GOT
03/03 10:03:45 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/187 sec
03/03 10:03:45 Info:

– -[ SignalPath ]---------------------------------------------
SignalPath Quality = Enhanced
Source Format=Flac 44100/24/2 Quality=Lossless
Output OutputType=HQPlayer Quality=Lossless SubType= Model=
HQPlayer filter=sinc-M, shaper=LNS15, mode=PCM, rate=0

03/03 10:03:46 Trace: [transport] [hqp/client] [localhost:4321] Disconnected: Connection reset by peer
03/03 10:03:46 Trace: [hqplayer] [localhost] Disconnected
03/03 10:03:46 Trace: [zone] HQP_AntipodesCX received transport control from endpoint integration: deselected
03/03 10:03:46 Trace: [zone HQP_AntipodesCX] Suspend
03/03 10:03:46 Info: [zone HQP_AntipodesCX] OnPlayFeedback Stopped
03/03 10:03:46 Info: [zone HQP_AntipodesCX] Canceling Pending Sleep
03/03 10:03:46 Trace: [zoneplayer/hqplayer] State transition WaitForHttp => Disconnected
03/03 10:03:46 Trace: [HQP_AntipodesCX] [Enhanced, 24/44 QOBUZ FLAC => 24/44] [STOPPED @ 0:00] A Love Like That - Katie Melua / Revaz Javakhishvili / Nikoloz Rachveli / Georgian Philharmonic Orchestra
03/03 10:03:46 Debug: FTMSI-B closed file for qo/BF34853D; open files:0

If SOTM connected via Direct Stream to CX, check that cable.
Check al your network cables, reboot your router,
Book a session :nerd_face::+1:

Have checked cables, rebooted router including shutting CX and SoTM down, waiting for router to boot up, then booted CX then SoTM. Still no joy, will have to be a support call.

I had previously successfully used the Preset HQP with Roon Server Auto with my K22. For a period of time I decided to take HQP out of the equation, and used Preset Roon Auto instead.

I would now like to use HQP again, but Embedded refuses to work. In Roon Setup I have added HQP using localhost (which previously worked for me). But when I use Preset HQP with Roon Auto, and then try to open HQP, I get a message saying that the K22 IP address is unreachable.

Pls see screenshots below.

I have cleared my browser cache; I have pressed the Refresh option next to the Solution preset; I have restarted both Roon and HQP in the Server page… nothing works and I’ve been trying to fix this over the past couple of days.

Any thoughts? This seems to be much more difficult than it should be.

I have paid for an HQP Embedded licence, so I’m not using the trial version.

I only wish i had an answer for you. I too had this message a couple of times but since doing many things in terms of reinstalling rebooting reactivating etc i have no issues opening HQP via AMS but there is something preventing Roon from accessing HQP. I was on the verge of purchasing the license given the sonic benefits i heard, but as stated in my original post i was worried about doing so just in case it wasnt the trial account that was the issue. Your post seems to have confirmed my worry.

My situation is the same, used Roon for som time when i first had my CX, gave HQP a go and was using it for weeks until one day, for no reason i am aware of, Roon just didnt want to find HQP.

Trying to recall but it is possible i may have reverted back to Roon for a sound comparison at some point during the listening session prior to problems starting. That does get me wondering whether in the background, some Roon Raat settings are still active, Roon/HQPlayer requires dedicated access to work.

Even though i have tried everything i can think of i cannot rule out it being something i have/havent done or a local network setup issue (cant rule out an ISP router update for example) so i have booked a support call for this Thursday. I will post progress on here when i can.

Thanks for the response. I’d like to be able to quickly switch back and forward between just using Roon for streamed music, and Roon + HQP, to see whether HQP does actually add something worthwhile to sound quality for my streamed music.

I realise that this may seem completely academic, given that I have already paid for the HQP Embedded licence, but firstly it’s the sort of thing that interests me, and secondly if it’s not really adding anything worthwhile then I’d prefer to take it out of the audio chain.

I have been told that HQP really only starts to make sense at rates of 384 and above, but I don’t exceed 192 in my listening. I have tried using higher rates using the i2s / HDMI input on my DAC, but didn’t like it with any of the HQP filters I tried.

I’m referring to PCM here, I’ve never dabbled with DSD.

In the few weeks i had to dabble with HQP even having HQP with no processing was a better realistic sound to my ears than with roon direct. I settled on Sinc-M with LNS15 at 256K and found the sound far more detailed, natural and BIG with bass texture and depth i have never heard from my system. I too havent played with DSD, and also found that anything above 256K ended up sounding etchy and unnatural, again to my ears. I have to bear in mind that i am using embedded on a CX, i am not sure at which point the available processing power comes into play.

Mind you this is all redundant if we cant get it working!

My own experience matches yours, in that anything above 192 seemed to emphasise the treble area, leading to too much etch and sharpness for my liking. However I was very happy with the basic default settings which Jussi recommends, which I don’t have off the top of my head (one of the poly sinc ones, anyway).

I have just used the Reinstall option for Roon within the K22 dashboard. This is a slight pain because you have to then log back into Roon, and also log back into Qobuz if you’re using it. Unfortunately this has not fixed the problem: either the K22 software and / or Roon cannot now find HQP Embedded.

I think my recommendation to anyone currently using HQP, and thinking of taking it out of their audio chain, is DON’T. ATM it appears that once you take it out you can’t get it back again. Not easily, anyway.