“Jitter” noise via RCA out on EX

I recently bought a used EX and love it via the USB out in to my external DAC. I have no issues at all.

However, I happened to connect up to the internal DAC and used the RCA outs whilst I bought a new DAC. When connected to my amp through the RCA out (and assume to be utilising the internal DAC) I get what I can only describe as electrical interference (jittery) noise coming through my speakers. This noise occurs without anything at all nearby being plugged in, it doesn’t even need the Ethernet connection to be plugged in for the noise to manifest. (I thought the interference may have come from external sources)

When it’s connected via the USB out everything is deathly silent, any ideas what could be causing this noise from the RCA out?

If I could upload a recording of the noise here I would, but don’t see an option.

Any ideas? The dealer I bought it from doesn’t seem to be able to get the fault at their end. It’s strange how it’s only via RCA out though and not USB


Upload a pic of the rear of the EX with the cables attached

Will do when it’s back with me, Elite in the UK have just had it back to test.

Cable arrangement was simply RCA out to Amplifier, the noise was present even without Ethernet connected (I used Network 1 input when I did have it connected though)


Do you know if your interconnect is shielded? It sounds like it’s picking up emitted noise.

I initially thought that but according to the Atlas website, my Equator interconnects use a twin shield. I also disconnected everything nearby so in theory there was no noise for it to pick up. I’ve used these cables successfully between phono stage and amp, and also between SUT and phono stage (shielding is essential with SUTs) so I can’t see it being the cables,


I also use the same cable from DAC to Amp without issue, it’s only when I use the interconnects from the EX direct to Amp that the issue occurs

I speculated that it was an emitted noise problem. If that’s true, then proximity to device emitting the noise is what matters, I believe the reason Mark wanted you to “upload a pic of the rear of the EX with the cables attached” was to see if cables may be situated in a way that puts one too close to a source of noise, Emitted noise problems can be the easiest to solve as it sometimes it can take just moving things around so that the susceptible cable or component is further away from the source of the noise.

I would try to eliminate that interconnect as a culprit by swapping in another to see if it causes the noise to vanish or maybe make the problem better or worse.

Hi, Mark

I’ve received the EX back today from Elite Audio who decided they couldn’t find a fault, yet the problem is still there? I can’t understand why they can’t find an issue but it persists here?. I’ve attached a photo of the EX as instructed but do you have an email address where I can forward the recording of the noise I’m experiencing?

I’ve tried using the stock Network Cable, and power cord and I have tried with the nearby modem switched on, and also without it switched on and the noise is present regardless.

The noise commences instantly as soon as you connect RCA cables to the analogue out. It affects both channels, not sure what else I can troubleshoot my end?



Try different interconnects.

I’ve tried 3 different sets, all shielded, all different brands to no avail

What amp are you connecting to, and to which particular input. Can you test with a different amp/preamp?

A EAR 834 integrated, using any of the inputs. I’ve got a Copland CTA402 due back to me shortly but don’t have anything immediate to test with in the mean time

Have been following this thread and its now more interesting as I have an EAR 834 and get a humming noise through the speakers when the streamer is connected via RCA. I put it down to earthing issues because if you unplug the streamer from the wall the noise stops.

I don’t get hum, just what I can only describe as like electrical jitter (as mentioned above). I don’t get anything via USB out, that’s perfectly silent.

Maybe a mismatch between amp and streamer then if both have minor issues (albeit they don’t sound identical issues)

Just to update, I’ve tried umpteen different cables and moved things around, still the problem persists. Reverted to USB out so not an urgent issue anymore, but still one I’d like to try and get to the bottom of if possible

Di you try with the Copland?