K22 player not “seeing” K41 server?

Setting up a new system: K22 and K41. On the K22 dashboard, under Server Device, the drop-down menu gives me only 2 options: One is K22, which obviously should not be the server, because that is handled by the K41. The other is “None.” So I selected “none.” I guess somehow the K22 knows that the server is somewhere else, but I still wonder whether the 2 devices are “seeing” each other the way they should.

You should be able to select the server from the drop down menu…

Ensure that you are using Direct Stream OUT on the K41 and Network IN on the K22.
We often have users plugging into the I2S RJ45 port, not saying that’s the case, but need to check.

If you are still having problems, book a support session

Thank you, Mark. The Ethernet cable goes from “Direct Stream” OUT on the K41 into Network on the K22. There is no option called “Direct Ethernet.” I guess I’ll book a support session to look into this a little further. Many thanks!

Oh that’s definitely something I would do. :man_facepalming:t3:

1 Like

I mean Direct Stream, I have edited my post :slight_smile:
Happy to assist

Just FYI, Mark, the wonderful folks at Support got me up and running quickly. Seems my K41 was stuck on the previous firmware and would not update because, well, you know. With the update “forced” from HQ, everything works great. Any estimate re “break-in time” for a new K41 recently married to a 3-month old K22? Many thanks! Michael