K50 has disappeared off Network

Not sure how to understand this, but I was using the K50 without problem yesterday, but this morning, despite restarting the K50, and even unplugging it, I can’t see the K50 on the network with MyAntipodes.
Have restarted router too. All else on the network seems fine.

Neither server nor player appear to be there.

Any suggestions?


Hi there Richard, can you confirm that this occurs when launching from myantipodes on our website?
Is the device visible thru myantipodes.com?
Is IPv6 enabled on your router?

Hi Mark,
Thanks for coming back to me so quickly.

The device is no visible through myantipodes.com

And if I understand correctly, the IPv6 is enabled on my Draytek router (see below)

Just as an update, did the gradual switching off of router and later switches, but still no sign of the K50.

Even swapped ethernet cables…everything else on network is functioning well.

Is the light blinking on the Ethernet input on the back of the K50?

Yes, blinking away. Mark is on the case, and I’m hoping a solution is near.

How did this end?

My K50 disappeared after it got stuck in the last (2/3) stage of the update

My issue was before the upgrade, and likely down to voltage fluctuations during a storm that may have corrupted the firmware. It may not have been helped also by having plugged the K50 into the Power Amp sockets on my Audioquest Niagara 7000. I thought current might have been preferable to any filtering, but I have now plugged it into the sockets recommended for digital devices. Hope that helps protect it better.

All back and good now, with AMS 3.1 uploaded.

What I will also share though is that refreshing the firmware at the service centre was massively delayed by a Synergistic Orange fuse blowing on switch-on, and the centre needing to get the Antipodes approved Shurter fuses. I won’t be using Synergistic fuses again with my K50. And I don’t think I am the first person to have problems with the Synergistic fuses.

What were the specs of the blown fuse?

1 Like

2.5A. I think the original fuses were 1.6A, but didn’t make a note of them. I usually buy Synergistic fuses at 1.3 - 1.6x the original value.

I just experienced this exactly. Tried to upgrade, never finished, and now I can’t see k50 server. How did you resolve? Thanks


If your unit does no longer show up on the network, Mark cannot approach the unit and can therefore not resolve the issue. It means you need to go to your dealer.

My dealer has the 3.1 software, but has so far not been able to put this on a bootable USB stick and transfer the new software to my unit. So I am still without my unit…:frowning:

For that reason, I have urged Mark to ensure all dealers have access to bootable software. Mark, what is the status there-off?