Musical Fidelity TriVista 21 DAC not working with a K22: what am I missing?

I have been using my K22 successfully with an Audio GD DAC. The K22 has flac files on a SSD drive (ripped from CDs), and otherwise I stream using Roon / HQP / Qobuz. The AGD DAC is connected to the K22 by digital coaxial cable, and then the AGD feeds a preamp. .

I bought a Musical Fidelity TriVista 21 DAC at a good price. It’s several years old, but is capable of 24/192, which is what I’ve been limiting HQP to anyway to interface with the Audio GD. So I thought that replacing the AGD DAC with the MF DAC in my chain was essentially a like for like swap. I used the same digital coax cable from the K22 into the back of the MF. HQP Embedded remained limited to 24/192 in the Configuration screen, and otherwise I didn’t change anything in the settings. It’s just swapping one DAC for another one, but otherwise the chain remains the same.

But I cannot get the MF to lock onto the digital signal from the music server. I’ve spent a good couple of hours going through all the settings for the K22, then HQP, then Roon. I cannot for the life of me work out what the problem is. The front of the MF DAC has lights for 96 and 192, and you can toggle between these using a switch on the back of the DAC. However, neither makes a difference. There are two lights on the front of the DAC for each of the Coax and Optical inputs, and another light for Locked: these lights are supposed to stop flashing and be a steady blue colour when the DAC locks onto the digital signal. This is not happening. This applies whether I play flac files from the K22 hard drive, or when I try to stream from Roon.

I’m stumped. The previous owner of the DAC assures me that it was working fine. Any thoughts? What am I missing?

Use HQPlayer to set max rate to 44.1k and see if you get a lock. Reducing variables can help with troubleshooting.

Just make sure that in HQPlayer config you have selected the correct output. The Solution dashboard should also reflect the right output. I have it set for USB out so you should use the other option for coax.

Which coax cable are you using?

What I like about Antipodes is that I know that with the help of this forum I’ll get to the bottom of any technical issues that pop up.

This MF DAC was sold in 2004-2005, so it’s relatively old technology and in a nutshell can’t handle the HQP processing. I realise that the more technically minded would have realised this already, but I’m not an expert on a lot of this stuff. I gather from the internet that this DAC has a Burr Brown DSD1792A 24/192 chipset.

My preferred HQP settings are the ones that Jussi tends to recommend, which off the top of my head is something like 1x = poly-sinc-gauss-long and Nx = poly-sinc-gauss-hires-lp. Recently I’ve preferred the Gauss1 dither. I only play PCM, not DSD.

Retaining these filters in HQP and dropping the sample rate to 44100 didn’t help. But as you might have guessed, setting the 1x and Nx filters to None in HQP enabled the MF DAC to lock onto the signal.

I have quickly played with going up the HQP filter scale a little, to see if the MF DAC can handle it. So far I’ve got it to lock on poly-sinc-lp, keeping the sample rate at 44100.

I guess my question now is whether anyone can advise me roughly how far ‘up’ the HQP filter scale, and also the sample rate scale, I’ll be able to go before the chipset gives up the ghost. I presume that those two parameters (filter and sample rate) are going to be intertwined, in terms of the ‘load’ on the chipset?

I honestly think the benefit of HQPlayer gets lost if the sample rate doesn’t extend to at least 4fs (384K). You’d likely be better off going native and using Squeeze instead. Obviously I’m just speculating here as I don’t know how that chipset behaves. You’ll have to let your ears decide.

As far as your issue, I wonder if this DAC supports all multiples of 44.1k and 48k up to 176.4/192. I kind of doubt it given that there’s a switch that toggles between 192 and 96. You may need to uncheck auto rate family and make sure you select a max rate that aligns with the switch setting. The problem with this approach is that 44.1k will get decimated as it’s not evenly divisible into those frequencies. This sounds like a suboptimal choice for scaling with HQP.

Thanks @kennyb123 . I’ve been playing more with this, and here’s where I’ve got to.

I’ve found out that the chipset in this DAC either does 96 or 192, and nothing else. The toggle switch on the DAC switches between the two rates, but I’ve been leaving it at 192.

I am able to use my favourite filters in HQP, which is great. I’ve set sample rate in HQP to Auto, which works OK, and rate limit to 176. I’ve tried 192 in rate limit, but the DAC won’t lock on to that. The max it will lock on to is 176. I don’t understand why that is, when technically the DAC can support 192.

I’ve taken photos of what I can see in HQP and in Roon, and they’re below. Obviously some of the music tracks in Qobuz are 96, and they’ve been working fine.

I guess my question is (more or less) do these settings look like the ones that are going to get the most out of this chain? The chain being Roon / Qobuz / HQP Embedded + K22 → this MF DAC → my preamp.

As a recap in the K22 Solution tab I have selected HQPlayer with Roon Auto.

In the HQP embedded screen I have selected Generic Backend as ALSA. In the ALSA backend I have the K22 as the Device: that’s the only option that appears there.

I will address the above first.

It can’t be true that it only supports 96 or 192 if you can get a lock at 176.4. I wonder if those two settings apply more to how it processes internally. Might it govern built-in upscaling so that it scales 44.1k to one or the other? I’m on a lunch break now so my time is limited otherwise I’d try to read up on it.

Question: Are you able to get a lock at 96k? This would help me make sense of it.

Yes, the lock at 176 puzzled me completely, as my understanding had been that the DAC only does 96 or 192. It does lock at 96, so I can answer that question.

I believe that this DAC uses the TI PCM 1792 chip. The data sheet for that is here:

It seems to me that Musical Fidelity’s implementation is the limiting factor here. The following manual makes things as clear as mud. It indicates that it supports sample frequencies up to 108kHz. My guess is that their implementation of the S/PDIF interface is the limiting factor with this. That you are locking at 176.4k could be just pure luck and maybe something they didn’t actually support. And I wonder if the 96K/192K switch isn’t some kind of marketing gimmick aimed at those who were looking for support of the latest buzzword.

Tri-Vista 21 DAC for PDF.PDF (

Only your ears can tell you that. I would suggest you also try sinc-M or sinc-L. Note that these are 3 dB lower than the other filters so account for that when doing comparisons.

Also you can go ahead and check auto rate family as it sounds like your DAC can support multiples up to 176.4. That should ensure that a 96K file plays as 96K as this shouldn’t be scaled to 176.4.

I came across this which might shed a little more light on the issue. Apparently the TriVista 21 internally upsamples to either 96KHz or 192KHz dependant on switch position, but doesn’t actually accept 192KHz.

1 Like

Great find! This is unfortunate as it most likely detracts from what HQPlayer can bring. I would use Squezze instead and just output in native format.

1 Like

Thanks as ever for this. Squeeze has been mentioned a couple of times, but I don’t know much about it. How would I use that in my chain? Is this correct?:

K22 Solution Preset is Squeeze Player with Roon Server.

In Roon enable Squeezebox in the Audio section.

Is that all I have to do? You mentioned output in native format: to achieve that do I need to limit the PCM rate in Squeeze Device Set Up in Roon to 48 khz? Or is it OK to leave it at 192?

Limit it to 176.4. I am feeling under the weather so I will respond again when I’m feeling better. Hope you can get things going with Roon/Squeeze.

No problem, understood. Get well soon.

I actually had to limit it to 48. I played some tracks from a Qobuz High Res playlist, with the max rate set to 192. The 1st couple played fine, but the 3rd didn’t until I set the max rate to 48. Thereafter all was good.

This is a photo of what I’m seeing in Roon, at least with some of the tracks (it varies):

You should try to find a way to get everything to play natively - except 192, which gets down-sampled to 96K.

You may have to go with Roon (Auto) and then use the DSP. I can’t find a screenshot of the settings, but it used to be that you could indicate what to do as far as sample rate at each frequency.

I’ve changed the K22 Solution to Roon (Auto), and then went into the Roon DSP. I changed Sample Rate Conversion to Custom, and then changed each rate as shown in the photo below.

I think this is what you mean?

I’ve also attached a photo of what Roon shows with these new settings.

Yes that’s it. Roon might be smart enough to handle all this on its own. You’ll have to see what happens when you play 192k. If your DAC can’t lock at 192K, what should ideally happen is that 192K gets down-sampled to 96K. You can enable that manually if Roon doesn’t do it automatically.