Network Share Struggle

Whilst general quite easy, I have in the past and now, struggled to set up a Network share on the K50. I have a new NAS (although same drives as before). The share details, share address, user name and password are all the same as I use for a second Bluesound OS system but it won’t mount.

From memory, Roon won’t accept a Network share with a special character in it , the NAS won’t allow a password without one in it but you can change that requirement on the NAS. Currently no special character in it.

I believe I’m one click/step away but I can’t see it! Cleared caches, I’m no expert but it’s not a complicated piece of work. I’am asking the support guys but timing will be while away so I thought I’d ask here. I’m using a Mac but file manager isn’t fussy?

I do not understand exactly where you got stuck. Are you trying to create a share:

1)from File Manager in the Antipodes server app?

2)direct on the NAS in an macOS environment?

  1. or did you create a share already and Roon can not read it?

Apologies for lack of clarity. This is through File Manager. Stuck is share “won’t mount” for address/credentials.

Share is between K50 and NAS setting via File Manager on a Mac.

No share. Not Roon related, I just noted that special characters in network share passwords sometimes causes problems, as a requirement or not allowed.

The same credentials work on Bluesound OS network share but won’t mount on K50 through File Manager.

It’s probably due to how you are specifying the path. What are you keying in for the destination folder on the “Include from NAS” screen? See the video here at 5:35.

I’ve tried most of the paths, /,//.,\ etc IP address, share name and have the share working fine on another system using the same credentials. It won’t mount. I’ve tried most combinations, new folders, user name and password work elsewhere. I’ve taken user name and password out for the screenshot.

Did you try user: guest no password

Good thought thank you. Tried but no cigar.

I will add another from my nas to my server after the grandkids leave and report back

1 Like

It might not be able to find the server “Hyperion” by that name. I always use the IP address of my NAS. I’ve set a reservation in my router so it can always be found at the same IP.

Mine would be something like:


The slashy things should be \ \\music

You can copy the address out of File Explorer on Windows.

1 Like

I’ve tried IP address (and the credentials have worked before). I actually deleted a previous share which I believe was working. I know it’s not the same but the share works with Bluesound. It also fails to mount on another NAS I have (which also works with Bluesound).

I removed my share from EX for my K30 server and recreated it. Here is what worked for me.
-make sure the destination folder is shared
-create new folder under music
-tap include and enter credentials

\\K30SERVER\storage\music\flac\PGGB 24b
user: guest
pass: blank

I found the destination using finder from one of my mac’s

I’ve tried IP address and the credentials have worked before. I actually deleted a previous share which I believe was working. I know it’s not the same but it works with Bluesound. It also fails to mount on another NAS I have.

Is SMB enabled on the NAS and is it shared, also I would move the NAS share on the K50 to

Thanks. SMB is enabled (works as a share with Bluesound Node), folder is shared. No joy.

By “move the share to” do you mean create a file such that path is… Still no mount.

Your slashes are in the wrong direction in your address \ \\Music

I usually try most combinations just in case, still no cigar-