New K21 Solution dashboard now unpopulated

I have a support session booked but not until Tuesday. Any ideas in the mean time? Thanks

  • New K21 arrived with AMSV4.4
  • I see K21 on network and completed storage set up, began copying files - all seemed normal
  • Now Solution dashboard is unpopulated (no presets listed and manually selecting K21 as source doesn’t take)
  • Server dashboard shows correct system info, but after trying a few buttons I get error “Failed to connect to port 80” (not IP address of K21).
  • I’ve restarted everything a few times

It appears you intend to use the unit as both server and player, correct?

First, have you tried to select a Source under “Player Settings” such as Roon or Squeeze?

Next, I see that no Output is selected in your Solutions dashboard. Are you able to select anything from the drop down menu such as USB or “Digital” such as AES? Mark helped me set up my AES connection to my DAC as “Digital.”

You shouldn’t need to select anything under “Server Settings” since the unit IS your server and should “self detect” as such.

If none of this works fro you I see no harm in updating to the latest software version IF permitted by the software.

I hope this may help until you can enjoy your remote session.

Yes, server and player.

The source drop down does give K21 as an option but selecting just reverts back to “none”. Same thing for output. I see my correct USB audio option but goes back to none. It seems as though the Solution dashboard is just hosed. I’m currently listening with Squeeze, but no server apps to select under drop down or using presets. Also, Server dashboard shows both Squeeze and Roon enabled which I thought wasn’t a good thing.

I thought about trying to update software but am nervous now. At least music is playing.

Thanks for the suggestions.

I suspect that the upgrade has a good chance of setting things straight. I believe the solution either way will be to reinstall AMS. In this case you can initiate that with the upgrade button that will lead to a complete upgrade. Since you already have a support call booked, might not be a bad move to give it a shot.

It is a tough call. If it is working and it is important to you that it continues to, I would wait until Monday or just before your support session Tuesday to maybe try it, then you would be without it for only a short time if it doesn’t. When I did mine it got stuck at the 67% like others, and I thought “oh damn, I don’t have it for 4 days”. I managed to try again and it worked, but if support sessions are booked for the next 3 days that shows there are many who were not as fortunate.

@ronl as I write this I see there is one spot open on Monday

1 Like

This did it for me. Thanks all for the comments and moral support!

Now running V5 and all is good.


Congrats and enjoy. And if you could cancel your appointment you free up a timeslot for the next problem owner. Seems a bit busy indeed, but as always, support is great at Antipodes.

1 Like