No native DSD from S30

I have an S30 into a Rockna Wavelight dac via USB. I use Roon and when I try to use native DSD it doesn’t show in roon upsampling settings. If I use dop it shows up. Any ideas why that may be?
Thanks in advance!:v:

Maybe Roon doesn’t think your DAC supports native DSD. Are you sure that it does?

It will go to DSD 512 native. Interestingly it will show in roon when squeezeplayer is used, but only to DSD 64.

Squeeze maxes out at DSD64. It sounds like you are wanting to upsample to higher rate DSD using Roon. That would be asking an awful lot of your S30.

Honestly I’m not a big upsampler and definitely wouldn’t stress the S30! But I was messing around with Roon as the player and noticed the DSD conundrum lol. I have this obsession to figure things out! I usually use squeeze/Roon, but like to toy around with the other options.

1 Like

When it comes to Roon, you could really hurt yourself by doing that. :grinning:

Roon will query the OS to try determine the DAC’s capabilities. The driver will report this back but also the DSD handling setting on the solution dashboard may plays a role when Roon is the player as well, I think. Roon then lights up capabilities based on what it learns.

You may want to search the Roon forums for mentions of your DAC.

A quick google throws up several posts that indicate the Rockna does not support Native DSD under Linux, for example post #966 at

On Linux, which is what Roon Rock is, the Wavelight can only do DSD via DoP. As per DoP protocol, maximum DSD rates are a function of the maximum PCM rates. The Wavelight is max PCM 384 which allows for DSD 128. The below is a good read to explain.

To play anything greater than DSD 128, you have to use Windows with the supplied drivers on the Rockna website.

I suggest you contact Rockna for clarification.