Qobuz app not playing

Wondering if anyone has experienced trouble with Qobuz recently? I’m trying to use my K50 to play from Qobuz and while songs and even entire albums end up in the queue, they won’t play - the highlight just keeps rapidly skipping down the list until the last song. This is recent, and while not attributable to AMSv4.2, it did start after the upgrade (but might have happened regardless, so I’m not claiming causality).
Squeeze is my player. This is an issue agnostic to all browsers as far as I can tell. I can play Qobuz directly in a browser through my computer speakers, and my account is current. And everything else plays successfully through the K50.

I had this issue some time ago. All other internet, wifi and streaming services, audio and video were working. Qobuz support advised rebooting all network devices, modem, router and switches. I was doubtful as only Qobuz was affected, but I did reboot everything and it did fix the issue for me.
All the best.

Thank you. I’m trying this now. Rebooting all network devices does not seem to help, but perhaps the third try will be the charm.

Apparently there has been an outage affecting Tidal and Qobuz. Should have been fixed by now.

Any idea on how to contact Qobuz? Their website seems to make the process opaque at best.

You could check the DNS on your router and change to /

I double checked, the DNS has been set to that for a while. I’m going to poke around a little more (mostly more rebooting probably) and if nothing works, will book an appointment.

thank you, and enjoy your well-deserved holidays.

1 Like

There is also a possibility of clearing the cache of Squeeze may assist.

Thank you all. I have tried all of the above and I’m still not able to listen to Qobuz directly from within the player window. I am not having any problem communicating with Qobuz from within the Player window. I purchased some music from there earlier today and it is showing up within the Qobuz ‘my purchases’ in the Menu although I have not yet added it to the K50 server. I can search Qobuz equally well from within the Player window, but just can’t seem to get things to play.
I’ll book some time with Mark next week if he has openings.

I had similar problem a couple months back with my initial download purchases from Qobuz. I am guessing the purchases did not export to your Music Folder for the K50. Instead, a folder called Qobuz was created on my Mac under Music in Finder. I copied the files from this Qobuz folder and added them to Antipodes>Storage>music>flac. I created folders with artist and album names first. (Note: I previously had a Small Green Computer server and the default folder system for it had the flac additional folder and I copied all over using same designations.). Oddly for me, I still was not able to find nor play the added music in Roon. I then tried Squeeze and saw the newly created folders and music and was able to play. Going back to Roon, the music did show up and play. There very possibly is an easier and more elegant resolution to access your Qobuz music purchases. I may have missed option to direct the downloads to correct location. Best of luck.

Hello. Unfortunately this is not the crux of my problem. I did discover, as you did, that when I purchase something from Qobuz and download it, the file ends up on the hard drive of the computer it is downloaded on, not the Antipodes Server. So I have to copy them over. And sometimes they are not immediately visible in My Music, but I just give it time.
My problem seems (to me) a little stranger and occurs when I try to use the Qobuz app from within the Antipodes App selection. The app opens normally and gives me options to play my music, search, play the favorites I identified in Qobuz via my web browser etc. Sometimes I want to play something I don’t own by streaming it via Qobuz. This is where I run into problems. Normally this works well - I can search for just about anything in the Qobuz ecosystem and play it through my K50. But a few weeks ago this stopped. I can still search/select songs/albums and see them added into my queue, but they won’t play. The other apps (e.g. Radio Paradise) work just fine.
It is very frustrating, but I really appreciate everyone trying to help me troubleshoot.

The apps on Antipodes all provide the ability to do a manual rescan. I’m not sure what you mean by the Qobuz app on Antipodes, but if you actually mean Squeeze, then go to settings and you will find an option for “Rescan Media Library”.

So it does sounds like you mean Squeeze. Be sure to check that you are still logged into Qobuz via the Squeeze setup. As you can see below, I am not logged in. I think that changed after the last update.

Thanks for being patient with me. Yes, when I am in the Antipodes Solution Dashboard and ‘hit’ Play, a new window opens up with the Logitech Media Server. Part of it looks like this:

The doubling up is a relatively recent thing that comes and goes. If I then scroll down to Apps and open it, I see this:

I can play Radio Paradise and Wefunk Radio. And I can open the Qobuz app and both see their list of music I have purchased and search within Qobuz. But trying to play anything from within the Qobuz app does not work. I can play music I have purchased from Qobuz that I have downloaded in my Music Library. But not from within that app.
Oddly, If I go to the Qobuz setup, it seems I am permanently logged into Qobuz - if I try to delete my account or password and then Save Changes, they autofill back in (I thought maybe logging out would help, but I can’t seem to do that).
Squeeze is now re-building my database for the second time and I’ll see if that helps.
Again, thank you You are all helping me get a better understanding of the inner workings of this device and being more careful of my terminology. I’m learning. Just wish I could figure this one out.

Try clearing your browser cache. I use Safari, so I can remove the website data for just the IP address of my Antipodes server as follows.

Thanks for explaining why you called it the “Qobuz app”. I always thought of these as plugins but now I see that the UI refers to them as apps.

I will experiment with this later tonight and see how it goes. It’s been a long time since I actually accessed Qobuz this way.

I use Roon when I want to stream from either my NAS or Qobuz. I appreciate the richer user experience when I am discovering music. For files I have stored on my Antipodes server, I will use only Squeeze because it gives the best sound quality.

I will circle back later to let you know if I figure out anything about the Squeeze Qobuz app,.

Calling off the dogs. I finally re-installed the Squeeze app from within The Antipodes Server dashboard window. That let me log back in to Qobuz and voila, things are working again. I have no idea why I had to re-install to do that but it seemed like something had gotten stuck (technical term).
I think you are probably correct about Qobuz being a plug-in instead of a true app. And your use of Roon for streaming intrigues me. I might end up trying that, although I hadn’t really imagined switching back and forth for different use-types.
Thank you again - one of the best parts of this discussion forum is that it prompts me to dig deeper into this strange world of non-analog audio.


My favorite feature in Roon is what they call “Roon Radio”. This begins to play songs like the song that started Roon Radio. Squeeze has something like this called “Don’t Stop the Music” but Roon is a lot smarter about it as it factors more into what it means to be “like” the first song. It’s a wonderful way to get introduced to unfamiliar music.

Switching between apps has gotten a lot easier thank to the new Solution Dashboard. I have this saved as a favorite so it only takes two clicks to switch between presets.


If the album is rapidly skipping ( assuming you are playing from a saved album in your library) it normally means the album is no longer available in Qobuz. You should find that the Tidal copy ( if they have it) should work.

glad to see you resolved your issues.
A good Forum and some patience will solve most glitches from my experience.
I think that once you give Roon a go you might find it hard to let go.
I know I did and I’m still using it as my Server but now with Squeeze as the Player. The Roon player is fine and I’ve used it for years but I find the Squeeze player to be a little smoother, especially after turning off FLAC Compression in Device Setup which is only visible when using Squeeze.