Server connection problem


I have a problem with my K50 bought from a previous owner.
Everything seemed to work fine.
I plugged it in, it turns on, I see it on My antipodes and everything seems fine.
But I can’t connect to the server part directly via iphone or Lenovo PC.
On the other hand, the player works when my Lenovo PC is considered to be the server.

Do you know where this could be coming from?
Is it possible that the server is damaged and not the player?
I don’t get any error messages on the dashboard.
I’ve already restarted my Internet box, reinstalled roon and reset it.

Thanks in advance for your feedback.

Hi Pat,

First things first.

Have you been on the Antipodes ‘Solution’ page (see below) and set your K50 to be set up with your chosen apps for the Server and Player?

If so, out of interest which ones have you selected?

Next, when you say you are trying to “connect to the server part directly via iphone” what do you mean by that? Normally one would merely be using the iPhone with either a controlling app such as Roon or you would be opening the Squeeze Material page, if you are using Squeeze, by pressing ‘PLAY’ as on my screenshot below.



Thank you for your reply.
I’ve looked at your help pages and haven’t found an answer to my problem.
I have taken out a roon subscription to control the K50.
I’ll try to give you some screenshots this evening to explain my problem in detail if you like.

So I’m able to use the K50 in Player mode, controlling it via my PC, which is considered a server. The K50 appears as a Roon Ready device, allowing me to listen to my music this way.

However, when I want to connect directly to the K50 in server + player mode, the connection fails. I’ve tested this with my iPhone or my PC and it’s the same problem. Roon tries to connect to the K50 and fails.

I’d like to ask you if, in terms of sound reproduction, there’s a big difference between using the K50 directly as a server, and my current results where it only appears as a player (antipodes D2)?

I’m in Paris, is it possible to have a local contact to see this subject live? Or to take care of it remotely directly via your platform?
(I’m french :slight_smile: )

Thanks in advance.


Hello Pat, I am not on the Antipodes team and I am just an enthusiastic owner but I am happy to try to help.

If you are using Roon the first thing you need to do is to go to the Antipodes Solutions page. You can get to this by going to and then selecting Setup from the menu bar on the top right.

Then you use the PRESETS pull down menu to select the Server and Player preset app combination you with to use. Although many will suggest the best sound is my using Roon on the server and Squeeze on the Player perhaps initially you should try the Roon (Auto) setting which installs Roon on both the Server and Player.

Then make sure you are not running Roon on your Lenover PC (if it is running, Quit Roon on the PC).

Next you can open the Roon app on your iPhone and it should say it can’t find the Roon Server it should give you the option to click to Select a Different Roon Server. Click on that and Roon should find the K50 server. It might ask you to deauthorise your Roon on the Lenover PC and you need to do that to connect to the Roon core on the K50.

Then when you are connected to the core on the K50 server you need to go into the Setup and Audio settings on Roon to select the K50 as the Player.

Through all of this I would be tempted to possibly have your Lenover PC powered down to ensure that Roon cannot connect to it.

Although I have written these instructions down from memory and not checked by going through the stages myself whilst typing they should be near enough hopefully to get you going.

If not then I suggest you tag @MarkCole on here and I am sure he will be able to sort it out for you.

After that you can possibly experiment with trying Roon on the K50 server and Squeeze on the K50 player. Many think this sounds better.

And after that you could try not using Roon and use Squeeze + Squeeze which is what I prefer!

Regards, Nick


Yes please share some screenshots.

It’s not clear what you mean by this so a screenshot will help.

Many apologies
I thought you were part of the staff.
I think the problem is with the Roon Core software.
I’ve attached the screenshots if they help you understand the problem.

1 Like

Hello Nick

Problem solved, after a month of searching.
The solution is very stupid but made me spend a lot of energy.
It was the hifi-specific RJ45 ethernet cable that was blocking some of the signal information.
When I tested it with a standard computer cable, everything was solved…
So users be careful not to get trapped like I did!

Kind regards,

1 Like