Squeeze with Roon Question - Digital Outs

I have 3.11 on both K50 server and player. I have enabled squeezebox support on Roon. With Roon Server active, if I select Squeeze Player, Roon does not show K50 digital, D2, as selectable audio zone in Roon. D2 does show if I select Roon as Player. What am I missing in wanting to try Roon with Squeeze with digital K50 output?

If you have Squeeze Server enabled as well as Roon Server, Squeeze wont be available to Roon as a player.
Also try re-starting Roon Server in the server dashboard, and/or Squeeze in the player dashboard

I had been playing Roon with only Roon Server selected. I had tried restarting Squeeze Player before and just did again. D2 Antipodes again not showing for this, though will show if I change to Roon Player and restart it. With Squeeze Player enabled, I do see my Mola-Mola RJ45 DAC and Lumin X1 DACS in Roon available audio zones.

So you have Squeeze support enabled in Roon?

Yes, I have Roon Support enabled.

Correction, I have Squeeze Support enabled in Roon.

If you disconnect all outputs from the K50 except for the one you are using ie just USB, or just digital, can you advise what happens?

I disconnected USB (was going to Mola-Mola), I2S (was going to DirectStream with DS not on), ethernet from K50 Direct Stream port (was going to Mola-Mola), and left AES/EBU on (going to Mola-Mola). Roon server is enabled and Squeeze support enabled on Roon. I selected Squeeze or player on K50 dashboard; only Digital shown as option and selected it. For Audio Zone in Roon, only my. iMac M1 and Lumin X1 are shown.

I do utilize a PF Buffalo switch ahead of the K50. Audio Sensibility ethernet cable connects to K50 and Sablon ethernet cable had then gone from K50 Direct Stream. Lumin X1 is utilizing fiber optic ethernet from the PF Buffalo directly to Lumin X1 fiber optic port with no other connection to Lumin RJ45 port.

Lumin X1 does play from Roon per the disconnections above.

I reconnected USB, I2S, and ethernet from K50 and refreshed Player dashboard. USB shows as available, but Digital still selected. Roon now shows iMac M1, Lumin X1, and Mola-Mola Makua RJ45. Both the Lumin X1 and Makua RJ45 are Roon Ready with their own players. I do have Roon option enabled on Lumin App. If I disable there, X1 will not show on Roon.

AMSv3.12 update has fixed the issue. Squeeze Player with Roon Server and Squeeze support enabled now working on digital outputs and K50player now shown as an Audio Zone. Mola-Mola Makua RJ45 also now shown as available Audio Zone as well as LUMIN X1 and iMac M1 with Roon Server, Squeeze Player, Squeeze support enabled in Roon.

The update was quite quick for me on both Server and Player; I already had AMSv3.11.

Thank you very much, Mark.

I am having a similar issue with my K50 not being displayed as an audio zone in Roon if I use Squeeze as the player and not Roon. I performed the v3.11 update last night and v3.12 update early this morning ET, set up the K50 as the Roon Core with Roon as the server and Squeeze as the player. No matter how many times I reset the Roon Core or rebooted the K50 or refreshed Squeeze as the player, the K50 using Squeeze as the player does not appear as an audio zone. I can change the player to Roon and the K50 will appear and work as normal. However I prefer using Squeeze as the player.
Mark R


Welcome to the forum.

My signal path now on Roon with Squeeze Player indicates for sound as Squeezebox streaming, SqueezeLite-RS and K50player as the Audio Zone. I did not have this showing on AMSv3.11 and do not know if it was showing on AMSv3.1.

Thanks, you reminded me that the player is displayed separately in Roon as Squeezebox and I have to enable Squeeze in Roon. It has been a while since I had initially set up the K50 with Roon as the server and forgot about enabling Squeeze.