Transfer of files from Qnap nas to k50

I have taken the plunge and purchased an ex demo k50. I am over the moon with the increase in sq. However I am now transferring all my files from a Qnap nas to the ssd on the K50. Just under 1 terrabyte of data, nearly 1000 cds all flac. I am using drag and drop but finding it extremely slow. Over 72 hours and I am just up to h in the files. Is there anyway to speed this up?

Over a network, with slow reading NAS drives no.

Thanks Mark, although that wasn’t what I wanted to hear, I will persevere.
One more question though I have noticed that a number of albums are incomplete. I am aware that some will be completed later. But some have remained incomplete for a couple of days, Is this normal.?My concern is I have only noticed the ones that are particular favourites and I am sure there are many more.

Sorry, I should of qualified my response.
Moving items across the network in one large copy is not a great idea IMHO.
When I do this and I’ve done it multiple times, I do it in one of two ways…
1/ copy small chunks, such as A-D in artists, then E-H etc
2/ Use sync software such as SyncBack Free to ensure that you have a mirrored copy on both NAS and Antipodes.

When in clients machines I do see that folks have difficulties in copying over.
We have tried to make it easy with the drag n drop window in the dashboard.
We are working on our own sync solutions but these are quite some way off release.

Thanks Mark, I am doing it in small batches, but still very slow. I should have clarified my second question. Some of my albums are not getting all of the tracks transferred. Cover art and meta data is there but only a few tracks. Example Emmy Lou Harris Wrecking Ball was uploaded about two days ago but is still showing only 4 tracks. Will this eventually resolve itself or should I be concerned.

I would suggest the syncing software, this will ensure that there are no issues.

1 Like

Agree totally. My NAS is my “source of truth”. I simply sync a folder down to my Antipodes. So essentially the Antipodes is a backup of that folder with the sync job making sure that it’s kept current.

1 Like

Any suggestions for good synching software for Mac?

I am busy these days doing the reverse (from my EX to a USB drive). My experience:

  1. The fastest approach is to use the “file manager” tool in the Antipodes server dashboard, e.g. with the USB drive mounted on the EX. However, this (for me) crashes with an error message for folders above (about) 50Gb.

  2. For the larger directories I am using (following Mark’s hint) FreeFileSync on my Mac with the USB drive mounted on the Mac. Speed is much slower (<10Mbps) and this (based on different combos I tried like connecting the Mac to the EX second LAN port) is purely due to the speed of accessing the disks on the EX, not a network bandwidth issue.

  3. I also played with rsync (with both EX and the USB mounted on the Mac a simple rsync -rWhv /Volumes/storage/music /Volumes/USBdrive/music works fine in Terminal) but I get same speeds as [2] above

  4. A simple online copy gives a bit higher speed but no control of the process.

Long story short after some errors it has taken me a week to back up my 2.2 TB library …

I have been using this for many years. They have never charged me for upgrades.

They have an express version too, but I have never tried it.

I tried this Kennyb123 , it keeps crashing my Mac and when it finds missing files on my k50 it archives them and they disappear from my NAS. Not sure what to do now.

You should only setup one way sync. Use the trial sync feature as it shows you exactly what it will do before it does it. Never, ever allow a program like this to make changes to your source directory.

All it takes is a very simple sync job and you should start with a simple test folder first.

I sync only one folder on my NAS to my Antipodes server. This is how it’s configured. The volume on the left is a folder on my NAS.


This looks like I have mine set up, not sure why it has archived files on the NaS that were missing on the k50. I will use trial from now on.
It is working fine now, thanks again for your help


1 Like