Unable to email from the contacts form page

Hi support,

I’m trying to email Antipodes Audio via the Buy>Distributors>Australia>email to request Australian pricing and how/where to purchase, but when I select the Submit button it changes to Processing… and remains that way and appears to not complete the sending request. I have tried this unsuccessfully on windows and apple devices, can you please assist with my issue.


Same for me, yesterday, using Chrome.

Tried again to fill out the Upgrade form…just stays stuck in processing.

Can you please clear your browser cache and try again, many apologies, as mentioned cannot replicate the issue and are looking into it

Thanks, @MarkCole

Tried clearing cache in Chrome, and also going Incognito, still stuck on ‘Processing’.

Tried Edge, cleared cache, went In Private, still got stuck on ‘Processing’.

Any further suggestions?

Just send me an email directly or message thru the forum for the meantime

Thanks, @MarkCole . Will do.

I may try a different device, too.

1 Like