Upgrading to AMSv4.0 - cannot configure remote Logitech Music Server

I’ve been using my S30 with an RME ADO-2 DAC via USB happily since early in the New Year.

My problem arises with “upgrading” to AMSv4.0. I went ahead and did it - even though I really should know better than to use a .0 release - and now I have two problems. No sound via USB (which I address in Upgrading to AMSv4.0: no more sound - #20 by dgrb); and an inability to point the S30 at my Logitech Music Server, which is running on another box.

I can’t run LSM on the S30 because my music is on a Synology NAS; if there was a possibility of the S30 connecting via NFS I could do that, but that option doesn’t seem available.

Under version 3.whatever (12) you could supply the address of the music server, although not in my experience 100% reliably, even though the interface said it was not necessary for most users.

Well it was for me because although LMS will run on the Synology box, they no longer support it (thanks Synology) and updating PERL will break it. More to the point, it’s stuck on version 6.something, which doesn’t support DSD files. Hence running another LSM on my debian server box.

This worked fine even though the path to the music was less direct than optimal: to the LMS server, which used NFS to access the music on the Synology, I never had any issues with network speed, even at 24-192 or DSD256.

But now the only way I can use the S30 is by pointing my web browser at the LMS and telling it to take control of the S30. I think, in all my cruising around the new interface, I did find a way of specifying another LMS than the one on the S30, but I can’t find that again and, indeed, find the new interface confusing at the very least and not well documented.
Everytime I restart the squeeze player (I presume it is still using Squeezelite, although that term appears nowhere in the new interface) or the S30 itself, it insists on connecting to LMS running on the S30.

So: two questions really: how do I point the S30 at my LMS? And can I stop LMS running on the S30 locally, given that I neither want nor need it?

The only option given on the Player Dashboard is to restart, which doesn’t help.

All assistance gratefully received.

You can point any Antipodes Server at a NAS for access of music.
Guide link…

This is done using the include button on the Player Dashboard via SMB.
This will enable the use of the S30 as a server player, playing all music from the NAS after it has been scanned.
Otherwise using it as you specify, you are essentially using only the “player” Squeezelite, so control of the S30 needs to be via the server I assume the Debian box.
If you wish to stop all servers on the S30 and use it only as a player then select Source to NONE this will turn the S30 to player only.

Appreciate the info, but unfortunately SMB won’t work because of the ludicrous Windows restrictions on filenames, specifically : and ? both of which I use quite frequently. And I really don’t fancy scanning 8.8TB of music files to fix that. Is NFS not feasible? I would have thought that it is more mature than SMB and certainly doesn’t impose those naming limitations.

However, setting Source to None does seem to do the trick, thank you.

I run LMS on my Antipodes and it can play music off of my Synology NAS.

Both Synology and Antipodes run Linux. Folders shared over SMB by Synology can be accessed by Antipodes. Both run an open source package to accomplish this.

The restrictions on filenames are provided to ensure compatibility. The simplest fix is to just avoid using those characters. I honestly can’t see why one would want to create unnecessary hurdles when it comes to sharing music.

Well, as I said I have 8.8TB of music and have evolved my naming structure over a decade or more.

Question marks and colons are necessary for - off the top my head - at least one album:

Q: Are we not men? A: We are Devo!

but the colon alone I use a lot, as in this track list of a live concert:

01 Announcer.flac’
‘02 Mendelssohn: Violin Sonata in F: Allegro vivace.flac’
‘03 Adagio.flac’
‘04 Assai vivace.flac’
‘05 Announcer.flac’
‘06 Prokofiev: Five Melodies Op.35bis: Andante.flac’
‘07 Lento, ma non troppo.flac’
‘08 Animato, ma non allegro.flac’
‘09 Andantino, un poco scherzando.flac’
‘10 Andante non troppo.flac’
‘11 Announcer.flac’
‘12 Franck: Violin Sonata in A: Allegretto ben moderato.flac’
‘13 Allegro.flac’
‘14 Recitativo - Fantasia, ben moderato.flac’
‘15 Allegretto poco mosso.flac’
‘16 Announcer.flac’
‘17 Boulanger: Nocturne.flac’

The restrictions MS placed on filenames are to preserve compatibility with DOS.

NFS is also open source and places no such antiquated restrictions.

However, thanks to Mark C, I now have a working system again.

Awesome, pleased you are up and running, NFS wont be implemented anytime soon, sorry.

Fortunately we are dealing with two Linux systems so file names written by one can be read by another.

Track names are read from the tags not the filename (unless the tag is missing). Filenames have limits, tags have fewer limits.

I’m sorry but I think SMB is more than capable of handling music libraries. The Linux and Mac implementations of this have been free from antiquated restrictions for a very long time.

Well, you’d certainly hope so, but it’s not always the case - although I admit I don’t think I’ve ever tried to connect one linux system to another via SMB.

However, every Android file manager I’ve ever tried insists in mungeing names with forbidden characters.

Perhaps more germanely, before I traded it in and moved up to the S30 I had, for a brief period, an Innuos Zen MkIII, also linux-based, which also used SMB to connect to my NAS and steadfastly refused to even acknowledge the existence of any directory or file with one of those characters in it. This was one (although not the only or most egregious) reason that I traded it in.

So I think my caution is justified in this instance.

Update: I just tried connecting from my linux laptop (Pop!_OS 22.04 LTS) to my linux server (Debian 10) using smbclient (version to connect to samba (version and it does indeed munge names with forbidden characters…

As to tags and filenames: yes, I know about this, but I have a fairly extensive collection of programs I have written over the years for manipulating tags from the command line (still, to my mind, preferable to a GUI in many cases) and generating the Title tag from the file name is one of the options I programmed and use all the time.

So, forgive me if I disagree: for my purposes SMB is not adequate for handing my music library, for reasons which are now over two decades out of date.

I hate software that thinks it knows better than I do, which is why I have never owned and never will own anything made by Apple.

Still, thanks to Mark C my system is now once again working as I want it to, so all is good.

But you chose a server that uses SMB. My advice had that in mind. The apps can be even pickier about the filenames so future headaches can be avoided by being mindful of the guardrails.

It drives me crazy that LMS doesn’t pick up all my album art. Sometimes embedding it in the files works, sometimes it also needs it to be saved as folder.jpg. And sometimes folder.jpg is ignored if the art is embedded. Maddening.

1 Like

Actually I’m not sure why you say I chose a server that uses SMB. I chose to use LMS which, in my case, is using files from an NFS-mounted directory.

As for album art: it is nice to have, but definitely no deal breaker for me. But the concensus on the net seems to be that LMS is best in class, I’ve certainly not found one which seemed better.

Your question pertained to an S30. That’s a server that uses SMB.

I’ll stop now.