USB Port K30 fails

I am running a K30 since beginning of this year and I was quite happy with the result. Up until now it was set up as a Roon Server and Roon player feeding a Linn DAC/Streamer via Ethernet.
Now I got my new DAC (Aries Cerat Helene) which I want to feed via USB. However, the DAC is not detected by Roon or the Antipodes dashboard. Moreover, I now realized that there never has been any output listed in my server dashboard (it was always “No available outputs”). This was never a problem for me since Roon was detecting the Linn system reliably. (what I mean is: maybe there always has been a problem, which I just did not realize because I was never using USB out.) I worked myself through the antipodes troubleshooting page regarding this matter but did not succeed. When I click on “output list” I receive the error message: "Error in alsa capabilities (v0.9.1) : aplay did not find any soundcard. (this sounds pretty linux-ish to me and not so much as an instruction for the normal end user, right?).
When I use the K30 as a server only and my Macbook as the Roon player connected via USB to the DAC everything is fine. The DAC is detected and things run smoothly, albeit far from the possible sound quality, I believe. Using the laptop with USB and other software (Audinirvana, JRiver) also works.
Is this a case for software support or is it clear at this point that the machine needs to be sent in anyways?

Update: I was checking all other USB ports for normal hard drive connection and they work (external disk mount upon USB connection).

Thanks a lot


Hi Conrad, in the server dashboard I think it is only normal there are no outputs shown. These outputs belong to the player part of your K30. However, the player should be able to find the usb input of your DAC.
Sometimes this doesn’t work immediately. In case of my EX player I do as follows: I restart my EX again. A hard reset and with power really switched off. After this restart, the EX and my usb dac make contact. I allways do this with volume on my amplifier on O or switched off. Restarting the usb connection can give a plopping sound. Good luck.

I’m guessing you checked this but it’s worth mentioning nonetheless. The USB input on the K30 has barely any grip. It never hurts to check the cable again.

If it checks out, go to their support page and book a time.

Hi there, as kennyb123 suggests, please check the seating of the USB, also ensure that this is done while the K30 is off, likewise connecting the DAC.
Some DACS have an interesting way of communicating, and the boot sequence can have an affect, have you tried, switching off the DAC removing the power waiting a moment or two, then re-insert power and boot the DAC, all the while the K30 is on?
Also a remote access session is available if required…

Thanks to everyone here!
I did everything you suggested but no change. The DAC is not recognised. At this point I seem to believe it must be something with the K30 because 3 different laptops and even my iPad will instantly see and feed the DAC when connected via USB.
I will probably receive a K50 for trial from my dealer here (thanks again for the great service!) together with some other DAC.
Playing through all iterations I will then go into the 1on1 support with the results.

Thanks again, I will keep you posted on the solution.


Maybe just a short question: is there anyone here on the forum with K30, K50 or similar connecting to an Aries cerat DAC (Helene or a version of Kassandra). Was it Plug and play?

1 Like

Did you try to swap for a - basic - USB cable? You did not state what USB cable you are using but some (custom) cables can give trouble with some connections. Maybe try a shorter USB cable?

Two basic ones of different lengths. One David Laboga 1m. All three work with the laptops.

Unless the laptops are running Linux, that might be lulling you into believing the cables aren’t the culprit.

Always good to have a USB cable on hand that meets the USB spec. If one of your basic cables meets the spec, then you can rule out the cable as being the culprit.

1 Like

Well, at least the two cheap cables say USB 2.0 standard…

1 Like

Do you have access to a different USB DAC that you can connect to the K30? If that is also not detected fault probably lies with the K30.

Please book a session for remote access, we can look at the set up.

1 Like

Short Update after the session: no software solution. Machine is going in hardware repair. I can not say more because I did not understand what was going on.
Thanks to everyone…

1 Like

I received a K50 for loan until the K30 is repaired. The K50 connects instantly via USB and everything worked within 5 minutes of setup.

1 Like

Good to read. Hopefully the K30 wiil be repaired soon.

Well. It is not that the loaned K50 is too much of a downgrade…

Don’t get used to it then :grin:

1 Like