AMS Update AMSv3.11

AMSv3.11 Upgrade

The software upgrade to v3.11 is now live.

Leave your music server booted up (not in standby) and it will receive the upgrade tool at 3.30am tonight or tomorrow night, your time, depending on your location. When you open the GUI or Dashboard from My Antipodes, the upgrade tool will open and you have the choice to begin the upgrade or skip it to do it later.

Once you start the upgrade, ignore all messages on the screen until it specifically asks you to REBOOT. Because an individual step says it is complete, does not mean the upgrade is finished. Interrupting it before you are asked to reboot will likely corrupt the software on your music server.

If you have a dual computer model, such as a K50 or K30, or if you connect directly between two music servers, such as between a S40 and S30, then you must complete the upgrade on the one running the Server apps first, reboot, and then complete the upgrade on the one running the Player apps. Do not upgrade them both at the same time.

Reboot by shutting down via the front panel power button. And then restart the music server via the same button.

What It Means

  • Already on v3.1?
    If you are already on AMSv3.1, then the v3.11 upgrade includes some bug fixes, application updates and upgrades that time had not allowed us to include in v3.1.
  • What if you do not get the upgrade tool?
    If you have left your music server on but not received the upgrade tool by 7 December 2021, get in touch with us so that we can get the upgrade started for you. The issue can be network communications issues, or only leaving your music server in standby rather than booted up and running.
  • What if you are not yet on AMSv3.1?
    You have not missed out. The upgrade process is cumulative and will deliver everything you require to be up to date at v3.11. Note that if you are upgrading from AMS3.0 or earlier, then this is a large upgrade in several steps, that you must not interrupt. Many users created problems for their music servers by not waiting for the instruction to ‘reboot’, and exiting the process before that instruction. Please be patient.

What It Contains

These are the key upgrades in AMSv3.11.

  • Roon Native DSD
    A bug prevented Native DSD enablement with Roon Server, and v3.11 fixes this.
  • Squeeze Player
    A bug made it difficult for Squeeze Server to find Squeeze Player on the network, and v3.11 fixes this.
  • Internal Audio
    The latest Operating System did not provide full support for some internal audio chips, which mainly affected Analog Outputs, and v3.11 fixes this.
  • My Antipodes
    Some users experienced problems with finding their music servers on the My Antipodes page. We have enhanced the code for the My Antipodes page to work with a wider variety of home network setups to address this.
  • Third-Party App Updates
    The v3.11 upgrade will update your applications to the latest versions that have passed testing on our operating system.
  • System Optimisation
    Users wanting to optimise sound quality should leave their music server on. But this can result in memory issues over time. AMSv3.11 introduces regular memory optimisations to avoid any deterioration of performance, making it even more advisable to leave your music server on.
  • SQUEEZE Remote Control
    AMSv3.11 includes a new SQUEEZE Server skin, based on Material, focused on making the interface easier to use. Since SQUEEZE is, in our opinion, the best sounding software, we intend to continue to innovate with this skin to make it both simple and complete for most users’ needs.
7 Likes

It sure is the best sounding. Thanks for the continued investment in usability.

3 Likes

Agreed and seconded re Squeeze being the best sounding and the Antipodes continued investment in its usability!!

1 Like

Well the Server was updated and the player is stuck on 3.1 and no longer is tagged as a k50 it is just blank…

And now unable to play Squezzelite played with all the settings
Still dead
@MarkCole

@clive101
Sent a PM regarding support

I have an K30 and upgraded as per instructions from version 3.10 to 3.11.
Since upgrade roon app won’t recognise roon core and prompts me to search for a different core. If I search for a core it sees the K30 but I get to the roon log-on page. When I try and log on it tells me I’m already logged on to a K30 and to either forget the K30 and then relog on as a new core
and sign out of the current core.
I am uncertain as to whether to action to forget the K30 and log on again or if there is an alternative

@Greggy
You will need to select the new core.
De-authorise previous core.
There is no alternative.
If you have Roon backups you can restore from there once in.

1 Like

Hi mark

For some reason now lost that option
If i start the app the roon core is visible but when I try on log in it just goes to the roon waiting screen and no other prompts
i didn’t get to the point of de-authorising etc
I do have back ups done for roon
The only other thing I did do after the upgrade and things not working is I went to the antipodes player and turned on roon ready as was set on sonos which I don’t use. I am using mac and when booting up it does give me the option of activating the mac core or connect to the the K30. If I chose K30 it just hangs with the roon icon flashing

Have you tried actually quitting out of Roon, in other words closing it down & then re-opening it? This should eventually bring you to the point you were at previously where you had the option available of de-authorising the old core.

Hi Mark,
Thank you so much for fixing the recent update. What a speedy reply 5 star service…!
I did not do the needed reboot between the server and player…I guess the player then did not work.
Now have the 3.11 player installed and working correctly.
Regards Clive.

1 Like

Many thanks to the @antipodes team!! I’m excited for the update and having Native DSD with Roon up and running again. Much appreciated!

@MarkCole - just a heads up that in my setup the My Antipodes page still does not see my devices. I have to use myantipodes.com, which is not a big deal. However, will this impact the ability for my devices to receive auto-updates…?

I understand this may have to do with my ISP modem / router. As an FYI, DNS servers can not be customized.

@MarkCole
Hi, while I tried to run the 3.11 update on the K50 server, it stuck when installing the Roon server package. After 2 hours I rebooted the server and roll-out again the 3.11 update and it happened again. Please advise how to proceed. Thanks

FWIW (i.e. nothing if you’re struggling), I upgraded fairly painlessly today. Download reboot, download reboot, then mess around for 20 minutes sorting Roon out. Squeeze sounds fab(er?).

Also our broadband went down in the middle of downloading various packages but it picked up again without intervention and finished. I might put a USB stick in the back for RoonBackups as setting up a link gets boring…

@desbiss
No it will not impact the use or features or the ability to receive updates.

@clive101
Enjoy the music

Yes, I left a crucial piece out of my reply.
If you cannot access Roon.

Exit out of all Roon remotes and software, force quit.

Go to the server dashboard and restart Roon Server.

Go to Roon remote, select core or click blue button to find new core.

Select core, deauthorise old core if asked.

Continue on with set-up

2 Likes

@sorin
From what I see on the screen is that the device is updating and in process.
However it is pulling data out of the repository at 33kbps, which is very slow.
Likely nothing to do with your internet, more access to the repository.
Patience I believe is required here for it to complete the download.

Hi Mark, I have a very fast network connection (1,5 GB), I am afraid is not my network fault. I roll out the upgrade 3 times, it works flawless until the roon server installing process. Unfortunately, the K50 is dead now, after 3 rebooting it cannot see the roon core,
Moreover, I cannot enter into the configuration dashboard neither on the server nor on the player - when I click on “update later” button, nothing happened, even before I started the upgrade process.

I changed the network port on my switch and finally it worked out on my 4th attempt. Everything is working perfect now! Thanks a lot Mark for your great support!