AMSv4.2 Released

AMSv4.2 was released 6pm 14 December 2022 NZ time (UTC+13Hrs). AMSv4.2 includes updates for HQPlayer Server and Spotify Connect, and patches to speed up the recognition of connected audio devices and to display CPU temperature for the EX.

Users with AMSv4.1 will see an update button at the solution dashboard, and all you need to do is click on it to run the update, and then reboot into AMSv4.2.

If you have a 2 computer device such as a K50, update the server first, reboot, update the player and reboot.
All done.

HQPlayer users will need to go to the server tab in the solution dashboard and restart HQPlayer server, and check the Network Backend and other HQPlayer Settings

2 Likes

All done & with no problems encountered.

Worthy of note is that despite my K50 having being powered down for the last couple of days (carrying out some minor electrical work & easier just to leave some equipment turned off), the prompt for upgrade was there immediately upon K50 start up.

I assume this is now the new norm & with no more waiting overnight to see if the update became available. Is that correct?

We did release and make live early, but with the new interface it is how we wish to proceed moving forward.

am I being crazy or there is some sound quality improvements in this version. Roon sounds tiny bit better (more open, more resolution ) in 4.2 for me .

Updated Oladra without any problems.

All good.

i did the update for my K50. My Antipodes shows the update for the server and for the player. When I start to play music on Qobuz, my player says “no player” ! What am I doing wrong ?

Have you set the solution dashboard?
What software are you using for playback?

@jazzbirder I had that after doing the update on my Oladra. I used the Solutions presets to load a different server and player then used it again to load the server and player that I actually wanted. This time the player was showing correctly.

1 Like

Yes to the first question. Squeeze and Qobuz to the second question.

I did everything with the Dell computer to update 4.2. I forgot to reboot the K50 itself. Note to self - reboot K50 after update

I did the update and Roon will not play on HQ player All my settings are correct for Roon Hq player. —- If I switch to regular roon I get music —- What do you suggest? Wonder if it could be something with the license of HQ player. Could the update change the fingerprint of the machine?

If you have re-started HQPlayer server and reset up the Network Audio Backend, and still have no joy, while also checking the sample rate to your DAC, then its possible that the server IP address has changed on reboot due to DHCP on the router, entering the IP of the server into Roon should be all that is needed.
Nothing to do with licence or fingerprint.

It appears it switch my Network Audio Backend to K50 only Check the other Backend with my Holo dac and it appears to be working. Very strange

@markcole I updated my K50 to AMS 4.2. The CPU utilization shows permanently 0% for server and player. A function was added again that only works after a few updates.

@erolo

My K50 server CPU usage display might initially & very briefly show slightly higher (around 3-5%) on initial entry to the server dashboard, but then drops back & fluctuates between showing 0% to 1%. The player dashboard CPU usage is anchored at displaying 0%.

It’s not of any particular concern to me as I’m not using anything that could stress either part, but out of inquisitiveness I did experiment to see if any alterations made to add a bit more load to the server section would make any difference to the displayed usage. They did not & the dashboard continued to display between 0 to 1%. (mostly 0%)

My K50 itself is functioning perfectly & like I said, for me having these displays functioning properly in the dashboards is not of any real concern but I believe you’re correct in that currently they don’t appear to actually work.

@MarkCole Really worried that upgrade to AMSv4.2 has went and caused an issue with my K40. The update has been running for over five hours and no change from the below :frowning:

Went into dashboard and clicked on update from 4.1 to 4.2 and instead of showing the progress it went straight to “This site can’t be reached” (see screenshot below).

Also going into webpage ‘MyAntipodes’ it doesn’t show my K40 (screenshot below).

Can you help / advise what I can do please?

@Celts88
The v4.2 upgrade take a few ticks to install.
Have you rebooted your server.
Looks like a network problem potentially.
Rebooted your remote computer and your network.

Mark, I’ve restarted the network and my laptop, and ran the v4.2 update but I can’t get by the reboot stage.

I restarted the K40 and got the below saying reboot for v4.2 update, but doesn’t matter if I reboot, or turn off / on the K40 it just goes to the same page and says I’m only on v4.1

Mark

I’ve made a booking for remote access session for tomorrow morning at 6.00am. I don’t know if that’s my time or your time, but I’ll leave the computer on overnight so you can jump in anytime it suits you (I’ll be going to work just after 6.00am tomorrow morning so hope you manage to get on before then).

Hi Mark. Looks like I have a similar problem like @Celts88. After updating my K30, a reboot was requested which is i still running after 30 minutes with the orange LED flashing. I’ve booked a remote session. Thanks, Bo