Squeeze playing but no sound - Possible solution

I had no sound from Squeeze though my S30/40/60 and posting here in case this ‘fix’ works for others, which was…changing the Preset on Solution dashboard over to Roon, and then back to Squeeze again (apologies if this is already posted somewhere, but I didn’t find it).
No amount of restarts of Antipodes boxes, modem, or restart of Squeeze within the dashboards helped in my case. My only hope is that this fix will still work if needed when my Roon subscription expires next month.
I’m sure Antipodes Support would have been happy to help me (again), but I think these issues are programmed to only happen on weekends :slight_smile: .

1 Like

Are you powering down your Antipodes servers? I only ask because with Squeeze has been tremendously reliable for me on both a K30 and a K50.

I did fully power down all 3 boxes (i.e. including the S60 supply), plus modem and switch, more than once, but would only get back to the same place, with Squeeze showing music to be playing, but no sound coming through. I also swapped out USB cables to the DAC, but the DAC display was showing a connection and that wasn’t the issue.

Switching over to Roon and back to Squeeze seemed like an odd workaround, but it was easy to do and it worked.

1 Like

Same here on EX/CX combo. This solution is my standard practice now everyday. What works works.

Nice solution. I wanted to try squeeze again for pggb and I received no sound. Unfortunately I selected reinstall which also reinstalled roon. That required a full restore. After all that I am back to MPD on my EX with K30 library added throughfile manager for pggb. Experimenting is fun though.

It just happened to me too. I inadvertently restarted the K50. When it came back up, Material indicated that my player couldn’t be found. I toggled the preset to Roon and then Back to Squeeze and all was good again.

1 Like

Same for me again today too. Same preset change process worked to get the sound back. @MarkCole, could you please give your thoughts on this?

My units were on when it happened, so potentially could be different from other’s experiences. Happened mid-song the first time.

Those who use Squeeze server regularly have likely noticed the occasional “restart required” message. This is displayed after Squeeze server auto updates components. I suspect the sudden appearance of this issue has to do with a bug introduced into that codebase. If so it’s a consequence of running open source software. It’ll likely likely to vanish at some point.

kennyb123 wrote : "Those who use Squeeze server regularly have likely noticed the occasional “restart required” message. " I’ve never gotten that message, but periodically and in differing ways have gotten the message “no player,” signifying there is no player available to send music to my DAC.

I have to say my Antipodes CX sounds terrific, but I’m not happy about the reboot. I don’t really need the management of Roon, but if it’s more stable with my CX. . . maybe I’ll look at that.

No need to reboot. This issue can be resolved by switching over to Roon and then back to Squeeze.

If you are using just the CX then you may have a different issue and should contact support.


Thanks. I’ll try that as a cure.

OK, I’m not 100% what issues people are experiencing here:

1/ Loosing connection, USB not recognised in the Player Dashboard
2/ Spanning tree protocol on router, making the connected devices loose connection at the router
3/ Squeeze not available after restart, switch of Auto app required
4/ Not waiting long enough for the optimisation script to run on start-up

For those with a CX and EX or S40+S30 you could try connecting both to the switch directly rather than to each other to see if that rectifies the issue, if so need a report back.

But I’d like some in depth clear and concise fault descriptions to try and analyse please.

Here’s what happened last night:

  1. K50 was set to Squeeze (auto) on Solution Dashboard
  2. K50 was shut down and restarted.
  3. After restart, K50 still set to Squeeze (auto) on Solution Dashboard, but Material browser showed no player available.

I will see if this is repeatable later tonight.

OK, thankyou, we believe this is a time thing, it does take a little time for all the operations and scripts to run, you may be able to access via network but the unit is still “starting”
We are looking into shortening this time.

1 Like

Mark and Kenny:

I believe the same thing happened to me using Squeeze (auto) on Solution Dashboard. It has repeated that behavior. I will see if I can repeat this, but in the mean time, I have a CX, with AMS 4.2 installed. Again, “no player available” immediately after playing music in Squeeze.
My issue isn’t can I repeat it, but can I get a player loaded and operational to test things out.

This is different to the issue described above.
So to be clear, you have Squeeze working, you play music, stop playing, and then go to play more music and there is no player?
Is Material web player closed ? Then re-opened? Or are you shutting down the server?
Have you tried, loading another pre-set doesnt matter which one, then go back to Squeeze Auto?
Do you have any other Sqeeze devices in the home?

It came back fine just now. It could very well be that more time was needed.

Hi Mark. I’m sorry for starting something so vague, with every chance it relates to 3rd party software. I am currently listening to music and loving it.
My first time it happened
(so to speak):

  • playing music with Squeeze via my Windows laptop (as remote if that’s the term), while also browsing other sites for DACs and Clocks (S20 perhaps). I.e. there is a small chance I did something silly myself while on the keyboard.
  • Sound stopped unexpectedly, but Squeeze played on silently on the laptop screen
  • Restarted S30/S40/S60, and laptop.
  • Restarted modem
  • Changed USB cable to my DAC
  • Did it again
  • Changed preset to Roon (did not try to play anything in Roon), then changed preset back to Squeeze.
  • Sweet sounds back and time for a bevy.

A couple of bevies later posted the very easy fix thinking it might assist others.

My second time:

  • Similar to above, but Squeeze was stopped or paused by me and some hours later when trying to play again the windows screen showed it playing, but no sound.
  • Changed presets - all sorted in less than a minute.

In both of my cases music restarted straight away after changing presets.

So to be clear, you have Squeeze working, you play music, stop playing, and then go to play more music and there is no player?>

Yes. To be more specific, if I use the “Menu” button to return to my list the player might disappear. If I use the “>|” button or its opposite on the player, that might cause the the “player” to no longer be available.

Is Material web player closed ? Then re-opened? Or are you shutting down the server?>

I’m not sure what the “material web player” is. I am accessing my CX only through a web browser at this point, I assume that is what you mean by “web player?”
I’ve tried switching the presets on the “Solution” page, as suggested by you and Kennyb123, from Squeeze (Auto) to Roon (Auto) and back. Today, that seems to have a strong correlation to getting the server to see my CX. I think, and may be wrong, that I tried that previously but . . . that previously didn’t work. I probably flailed about trying to “re-set” the player in random ways without tracking my process logically.
What I tried previously to cure this issue - it’s been going on for over a month - was to close and reopen the browser, to restart the Mac Mini I’m running “myantipodes.com,” and to even turn off the CX. These last worked fitfully and I cannot tell you which worked with any regularity.

I do not have any other Squeeze devices in our house.

You and Kenny seem to have a good solution. It seems the suggestion has resolved a few issues. If you’ll allow me to practice more rigor in working with Squeeze, I’ll check back in if I continue to have problems or if your practice resolves my issues. I will also look for any follow-up from you, Mark, or Kennyb123.

For now, thanks!